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SESSION 1:   CREATE AND APPLY STYLES IN THE DOCUMENT 

A style is a set of formats that you can apply to selected pages, text, frames, and other 

elements in your document to quickly change their appearance. When you apply a 

style, you apply a whole group of formats at the same time.  

Styles are logical attributes. Using styles means that you stop saying “font size 14pt, 

Times New Roman, bold, centered”, and you start saying “Title” because you have 

defined the “Title” style to have those characteristics. In other words, styles mean that 

you shift the emphasis from what the text (or page, or other element) looks like, to 

what the text is.  

Styles help improve consistency in a document. They also make major formatting 

changes easy. For example, you may decide to change the indentation of all 

paragraphs, or change the font of all titles. For a long document, this simple task can 

be prohibitive. Styles make the task easy.  

OpenOffice.org supports the following types of styles:  

• Page styles include margins, headers and footers, borders and backgrounds. In 

Calc, page styles also include the sequence for printing sheets.  

• Paragraph styles control all aspects of a paragraph’s appearance, such as text 

alignment, tab stops, line spacing, and borders, and can include character 

formatting.  

• Character styles affect selected text within a paragraph, such as the font and size 

of text, or bold and italic formats.  

• Frame styles are used to format graphic and text frames, including wrapping type, 

borders, backgrounds, and columns.  

• Numbering styles apply similar alignment, numbering or bullet characters, and 

fonts to numbered or bulleted lists.  

• Cell styles include fonts, alignment, borders, background, number formats (for 

example, currency, date, number), and cell protection.  

• Graphics styles in drawings and presentations include line, area, shadowing, 

transparency, font, connectors, dimensioning, and other attributes.  
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• Presentation styles include attributes for font, indents, spacing, alignment, and 

tabs.  

Applying styles 

OpenOffice.org provides several ways for you to select styles to apply.  

Using the Styles and Formatting window  

1) Click the Styles and Formatting icon located at the left-hand end of the object 

bar, or click Format > Styles and Formatting, or press F11.  

The Styles and Formatting window shows the types of styles available for the 

OpenOffice (OpenOffice.org) component you are using.  

Figure 1.1 shows the window for Writer, with Page Styles visible.  

 

 

 

 

Figure1.1: The Styles and Formatting window for Writer, showing paragraph styles  

You can move this window to a convenient position on the screen or dock it to an edge 

(hold down the Ctrl key and drag it by the title bar to where you want it docked).  

2) Click on one of the icons at the top left of the Styles and Formatting window to display 

a list of styles in a particular category.  

3) To apply an existing style (except for character styles), position the insertion point in 

the paragraph, frame, or page, and then double-click on the name of the style in one 

of these lists. To apply a character style, select the characters first.  
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Using Fill Format mode  

Fill format mode is used to apply a style to many different areas quickly without having 

to go back to the Styles and Formatting window and double-click every time. This 

method is quite useful when you need to format many scattered paragraphs, cells, or 

other items with the same style.  

1) Open the Styles and Formatting window and select the style you want to apply.  

2) Click the Fill Format mode icon .  

3) To apply a paragraph, page, or frame style, hover the mouse over the paragraph, 

page, or frame and click. To apply a character style, hold down the mouse button 

while selecting the characters, clicking on a word applies the character style for that 

word. Repeat step 3 until you made all the changes for that style.  

4) To quit Fill Format mode, click the Fill Format mode icon again or press the Esc 

key. An important point to note here is that when this mode is active, a right-click 

anywhere in the document undoes the last Fill Format action. Be careful not to 

accidentally right click and thus undo actions you want to keep.  

 

Creating New (Custom) Styles  

You may want to add some new styles. You can do this in two ways:  

Creating a new style from a selection 

You can create a new style by copying an existing manual format. This new style 

applies only to this document; it will not be saved in the template.  

1. Open the Styles and Formatting window and choose the type of style you want to 

create.  

2. In the document, select the item you want to save as a style.  

3. In the Styles and Formatting window, click on the New Style from Selection icon 

(refer Figure 1.2).  
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Figure 1.2: Naming a new style created from a selection 

4. In the Create Style dialog, type a name for the new style. The list shows the names 

of existing custom styles of the selected type. Click OK to save the new style.  

 

Dragging And Dropping To Create A Style  

You can drag and drop a text selection into the Styles and Formatting window to create 

a new style.  

Select some text and drag it to the Styles and Formatting window. If Paragraph Styles 

are active, the paragraph style will be added to the list. If Character Styles are active, 

the character style will be added to the list.  

Modifying Styles  

OpenOffice.org provides several ways to modify styles (both the predefined styles and 

custom styles that you create):  

• Updating a style from a selection  

• Load or copy styles from another document or template  

 

Any changes you make to a style are effective only in the current document. To change 

styles in more than one document, you need to change the template or copy the styles 

into the other documents.  
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Updating A Style From A Selection  

To update a style from a selection:  

1. Open the Styles and Formatting window.  

2. In the document, select an item that has the format you want to adopt as a style.  

3. In the Styles and Formatting window, select the style you want to update (single-

click, not double-click), then long-click on the arrow next to the New Style from 

Selection icon and click on Update Style(Refer Figure 1.3). 

 

 

 

 

 

Figure 1.3: Updating a style from a selection 

Loading Styles From A Template Or Document 

You can copy styles by loading them from a template or another document:  

1. Open the document you want to copy styles into.  

2. In the Styles and Formatting window, long-click on the arrow next to the New Style 

from Selection icon, and then click on Load Styles.  

 

 

 

 

Figure 1.4. Copying styles from a template into the open document 
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3. On the Load Styles dialog (Figure 1.4), find and select the template you want to 

copy styles from.  

4. Select the categories of styles to be copied. Select Overwrite if you want the styles 

being copied to replace any styles of the same names in the document you are 

copying them into.  

5. Click OK to copy the styles. You will not see any change on screen.  

 

To copy the styles from another document, click the From File button to open a 

window from which you can select the required document. 

 

ACTIVITY 

 

1. Write your resume/ Bio Data and apply different styles on it, 

2. Create a pamphlet on Cyber Awareness. Apply different styles on it 

 

QUESTIONS 

 

1. What are Styles ?. What are the advantages of using styles 

2. Give  any four styles supported by OpenOffice.org 

3. How can we create our own styles  

 

 

SESSION 2. INSERT AND USE IMAGES  

Relevant  Knowledge 

Images can be added to a document in several ways: by inserting an image file, directly 

from a graphics program or a scanner, or from the Open Office Gallery.  

Inserting An Image File  

When the image is in a file stored on the computer, you can insert it into an Open 

Office document using either of the following methods:  
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Drag and Drop  

1. Open a file browser window and locate the image you want to insert.  

2. Drag the image into the Writer document and drop it where you want it to appear. 

A faint vertical line marks where the image will be dropped.  

This method embeds (saves a copy of) the image file in the Writer document. To link 

the file instead of embedding it, hold down the Control+Shift keys while dragging the 

image.  

 

Insert Picture Dialog  

 

1. Click in the Open Office document where you want the image to appear.  

2. Choose Insert > Picture > From File from the menu bar. 

3. On the Insert Picture dialog (see Figure 1.5), navigate to the file to be inserted, 

select it, and click Open.  

At the bottom of the dialog are two options, Preview and Link. Select Preview to 

view a thumbnail of the selected image on the right, so you can verify that you have 

the correct file. See below for the use of Link.  
 

 
Figure 1.5. Insert picture dialog 
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Inserting An Image From The Clipboard 

Using the clipboard, you can copy images into an Open Office document from another 

Open Office document and from other programs. To do this:  

1. Open both the source document and the target document.  

2. In the source document, select the image to be copied.  

3. Move the mouse pointer over the selected image and press Control+C to copy the 

image to the clipboard.  

4. Switch to the target document.  

5. Click to place the cursor where the graphic is to be inserted.  

6. Press Control+V to insert the image.  

If the application from which the graphic was copied is closed before the graphic is 

pasted into the target, the image stored on the clipboard could be lost. 

 

Inserting An Image Using A Scanner  

If a scanner is connected to your computer, Open Office can call the scanning 

application and inserted the scanned item into the Open Office document as an image. 

To start this procedure, click where you want the graphic to be inserted and select 

Insert > Picture > Scan > Select Source.  

Although this practice is quick and easy, it is unlikely to result in a high-quality image 

of the correct size. You may get better results by scanned material into a graphics 

program and cleaning it up there before inserting the resulting image into Open Office.  

Inserting An Image From The Gallery  

The Gallery provides a convenient way to group reusable objects such as graphics and 

sounds that you can insert into your documents. The Gallery is available in all 

components of Open Office. It does not come with many graphics, but you can add 

your own pictures or find extensions containing more graphics. To insert a Gallery 

image into a Writer document:  
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1. To open the Gallery, click on the Gallery icon (located in the right side of the 

Standard toolbar) or choose Tools > Gallery from the menu bar.  

2. Navigate through the Gallery to find the desired picture.  

3. To insert the picture, click and drag it from the Gallery into the Writer document. You 

can also right-click on the picture and choose Insert>Copy.  

Figure 1.6 shows an example of an image dragged from the Gallery.  

 

 

Figure 1.6. Inserting an image from the Gallery 

 

By default, the Gallery is docked above the Writer workspace. To expand the Gallery, 

position the pointer over the line that divides it from the top of the workspace. When 

the pointer changes to parallel lines with arrows, click and drag downward. The 

workspace resizes in response.  



12 | P a g e  

 

To expand the Gallery without affecting the workspace, undock it so it floats over the 

workspace. To do so, hold down the Control key and double-click on the upper part 

of the Gallery next to the View icons.  Double-click in the same area while holding 

down the Control key to dock it again (restore it to its position over the workspace).  

When the Gallery is docked, to hide it and view the full Writer workspace, click the in 

the middle of the thin bar separating the Gallery from the workspace.  

To close the Gallery, choose Tools > Gallery to uncheck the Gallery entry, or click 

on the Gallery icon again.  

Modifying An Image  

When you insert a new image, you may need to modify it to suit the document. Here 

we will discuss the use of the Picture toolbar, resizing, cropping, and a workaround to 

rotate a picture.  

Using The Picture Toolbar  

When you insert an image or select one already present in the document, the Picture 

toolbar appears. You can set it to always be present (View > Toolbars > Picture). 

Picture control buttons from the Picture toolbar can also be added to the Standard 

Toolbar.   

Two other toolbars can be opened from this one: the Graphic Filter toolbar, which can 

be torn off and placed elsewhere on the window, and the Color toolbar, which opens 

as a separate floating toolbar.  

From these three toolbars, you can apply small corrections to the graphic or obtain 

special effects.  

Graphics mode  

You can change color images to grayscale by selecting the image and then selecting 

Grayscale from the Graphics mode list.  

Flip vertically or horizontally  

To flip an image vertically or horizontally, select the image, and then click the relevant 

icon.  
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Filters  

Table 1 provides a short description of the available filters, however the best way to 

understand them is to see them in action. Feel free to experiment with the different 

filters and filters settings, remembering that you can undo all the changes by pressing 

Ctrl+Zor Alt+Backspaceor by selecting Edit > Undo.  

Color 

Use this toolbar to modify the individual RGB color components of the image (red, 

green, blue) as well as the brightness, contrast, and gamma of the image. If the result 

is not satisfactory, you can press Ctrl+Z to restore the default values.  

Table 1: Graphic filters and their effects 

Icon  Name  Effect  

 
Invert  

Inverts the color values of a color image or the 

brightness values of a grayscale image.  

 Smooth  Softens the contrast of an image.  

 Sharpen  Increases the contrast of an image.  

 
Remove noise  Removes single pixels from an image.  

 
Solarization  

Mimics the effects of too much light in a picture. A 

further dialog box opens to adjust the parameters.  

 

Aging  

Simulates the effects of time on a picture. Can be 

applied several times. A further dialog box opens to 

adjust the aging level.  

 
Posterize 

Makes a picture appear like a painting by reducing 

the number of colors used.  

 
Pop Art  Modifies the picture dramatically.  

 
Charcoal  Displays the image as a charcoal sketch.  

 

Relief  

A dialog box is displayed to adjust the light source 

that will create the shadow and, hence, the relief 

effect.  

 Mosaic  Joins groups of pixels into a single area of one color.  
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Transparency  

Modify the percentage value in the Transparency box on the Picture toolbar to make 

the image more transparent. This is particularly useful when creating a watermark or 

when wrapping the image in the background.  

 

Using The Formatting Toolbar And Picture Dialog  

When an image is selected, you can customize some aspects of its appearance using 

the tools available on the Formatting toolbar as well as in the dialog that is shown by 

right-clicking on the image and selecting Picture. You can, for example, create a 

border around the image, selecting style and color; or you can (in the Borders page of 

the Picture dialog) add a shadow to the image.  
 

Cropping Images  

When you are only interested in a section of the image for the purpose of your 

document, you may wish to crop (cut off) parts of it. To start cropping the image, right 

click on it and select Picture from the pop-up menu. In the Picture dialog box, select 

the Crop page (see Figure 1.7).  

Figure 1.7: The options available when cropping a picture 
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In the Crop page, you can control the following parameters:  

Keep scale / Keep image size  

 

When Keep scale is selected (default), cropping the image does not change the scale 

of the picture.  

When Keep image size is selected, cropping produces enlargement (for positive 

cropping values), shrinking (for negative cropping values), or distortion of the image 

so that the image size remains constant.  

 

Left, Right, Top, and Bottom  

 

The image is cropped by the amount entered in these boxes. For example, a value of 

3cm in the Left box cuts 3 cm from the left side of the picture.  

• When Keep scale is selected, the size of the image also changes, so in this example 

the width will be reduced by 3 cm.  

• When Keep image size is selected, the remaining part of the image is enlarged 

(when you enter positive values for cropping) or shrunk (when you enter negative 

values for cropping) so that the width and height of the image remains unchanged.  

 

Width and Height  

The Width and Height fields under either Scale or Image size change as you enter 

values in the Left, Right, Top, and Bottom fields. Use the thumbnail next to these 

fields to determine the correct amount by which to crop.  

 

Resizing an Image  

The inserted image might not fit perfectly into the document if it is too big or too small. 

In these cases, you can use Writer to resize the image.  

1. Click the picture, if necessary, to show the green resizing handles.  

2. Position the pointer over one of the green resizing handles. The pointer changes 

shape giving a graphical representation of the direction of the resizing.  
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3. Click and drag to resize the picture.  

4. Release the mouse button when satisfied with the new size.  

The corner handles resize both the width and the height of the graphic object 

simultaneously, while the other four handles only resize one dimension at a time.  

 

To retain the original proportions of the graphic, Shift+click one of the corner handles, 

then drag. Be sure to release the mouse button before releasing the Shift key.  

 

Be aware that re-sizing a bit-mapped (raster) image will adversely affect the 

resolution, causing some degree of blurring. It is better to externally size your picture 

correctly before insertion into your presentation, if possible.  

Figure 1.8 shows three examples of an image inserted into a document and resized.  

 

Figure 1.8. Three examples of resized images, plus the original image 
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For more accurate resizing, use either the Crop page of the Picture dialog box (Figure 

1.7) or, for images, the Type page of the Picture dialog box. On the Crop page you 

can adjust the following settings:  

 Scale Width and Height: specify in percentages the scaling of the picture. The size 

of the image changes accordingly. For a scaled resizing, both values should be 

identical.  

 Image size: specify the size of the image in your preferred unit of measurement. 

The image enlarges or shrinks accordingly.  

 Original size button: when clicked, restores the image to its original size.  

In the Type page of the Picture dialog box, select the Relative option to toggle 

between percentage and actual dimension. For a scaled resizing, select the Keep ratio 

option. As for the Crop page, clicking on the Original Size button restores the original 

image size.  

 

Rotating a Picture  

Writer does not provide a tool for rotating a picture; however, there is a simple 

workaround:  

1. Open a new Draw or Impress document (File > New > Drawing or File > New > 

Presentation).  

2. Insert the image you want to rotate. You can use any of the mechanisms described 

in “Error! Reference source not found.” on page Error! Bookmark not 

defined., although there are some slight variations in the position of the menu 

entries and icons.  

3. Select the image, then in the Drawing toolbar (shown by default at the bottom of 

the window in Impress and Draw), select the Rotate icon from the Effects tear-

off toolbar .  

4. Rotate the image as desired. Use the red handles at the corners of the picture and 

move the mouse in the direction you wish to rotate. By default the picture rotates 

around its center (indicated by a black crosshair), but you can change the pivot 

point by moving the black crosshair to the desired rotation center.  
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To restrict the rotation angle to multiples of 15 degrees keep the Shift key pressed 

while rotating the image.  

5. Select the rotated picture by pressing Ctrl+A, then copy the image to the clipboard 

with Ctrl+C.  

6. Finish by going back to the location of the Writer document where the image is to 

be inserted and pressing Ctrl+V.  

 

Creating Drawing Objects  

To begin using the drawing tools, display the Drawing toolbar (Figure 1.9), by clicking 

View > Toolbars > Drawing.  

Figure 1.9. The Drawing toolbar   

To use a drawing tool:  

1. Click in the document where you want the drawing to be anchored. You can change 

the anchor later, if necessary.  

2. Select the tool from the Drawing toolbar (Figure 7). The mouse pointer changes to 

a drawing-functions pointer .  

3. Move the cross-hair pointer to the place in the document where you want the 

graphic to appear and then click-and-drag to create the drawing object. Release the 

mouse button. The selected drawing function remains active, so you can draw 

another object of the same type.  
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4. To cancel the selected drawing function, press the Esc key or click on the Select 

icon (the arrow) on the Drawing toolbar.  

5. You can now change the properties (fill color, line type and weight, anchoring, and 

others) of the drawing object using either the Drawing Object Properties toolbar or 

the choices and dialog boxes reached by right-clicking on the drawing object.  

Set or Change Properties For Drawing Objects  

 

To set the properties for a drawing object before you draw it:  
 

1. On the Drawing toolbar (Figure 9), click the Select tool.  

2. On the Drawing Object Properties toolbar (Figure 1.10), click on the icon for each 

property and select the value you want for that property.  

3. For more control, or to define new attributes, you can click on the Area or Line 

icons on the toolbar to display detailed dialog boxes.  

The default you set applies to the current document and session. It is not retained when 

you close the document or close Writer, and it does not apply to any other document 

you open. The defaults apply to all the drawing objects except text objects.  

 
Figure 1.10. Drawing Object Properties toolbar 

 

To change the properties for an existing drawing object:  

1. Select the object.  

2. Continue as described above.  
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You can also specify the position and size, rotation, and slant and corner radius 

properties of the drawing object:  

1. Right-click on the drawing object and then click Position and Size from the pop-

up menu. The Position and Size dialog box is displayed.  

2. Choose any properties, as required.  

Resizing a Drawing Object  

The same considerations for resizing an image apply also to resizing an object. Select 

the object, click on one of the eight handles around it and drag it to its new position. 

For a scaled resizing, select one of the corner handles and keep the Shift key pressed 

while dragging the handle to its new position.  

For more sophisticated control of the size of the object,  

 Select Format > Object > Position and Size from the menu bar.  

 Use the Position and Size dialog box to set the width and height independently.  

 If the Keep ratio option is selected, then the two dimensions change so that the 

proportion is maintained, allowing for a scaled resizing.  
 

Grouping Drawing Objects  

To group drawing objects:  

1. Select one object, then hold down the Shift key and select the others you want to 

include in the group. The bounding box expands to include all the selected objects.  

2. With the objects selected, hover the mouse pointer over one of the objects and 

choose Format > Group > Group from the menu bar or right-click and choose 

Group > Group from the pop-up menu.  
 

You cannot include an embedded or linked graphic in a group with drawing objects.  

Positioning Image/Graphics Within The Text  

When you add a graphic to a text document, you need to choose how to position it 

with respect to the text and other graphics. The positioning of graphics is often rather 
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time consuming and may be very frustrating for both inexperienced and experienced 

users. As Writer is a word processor rather than a desktop publishing program, there 

are some limitations to the flexibility in positioning images and it takes time to get 

things exactly as you would like them.  

Positioning of a graphic is controlled by four settings:  

1. Arrangement refers to the placement of a graphic on an imaginary vertical axis. 

Arrangement controls how graphics are stacked upon each other or relative to the 

text.  

2. Alignment refers to the vertical or horizontal placement of a graphic in relation to 

the chosen anchor point.  

3. Anchoring refers to the reference point for the graphics. This point could be the 

page, or frame where the object is, a paragraph, or even a character. An image 

always has an anchor point.  

4. Text wrapping refers to the relation of graphics to the surrounding text, which may 

wrap around the graphic on one or both sides, be overprinted behind or in front of 

the graphic, or treat the graphic as a separate paragraph or character.  

The settings can be accessed in a number of ways, depending on the nature of the 

graphics:  

1. From the Format menu, where you can find Alignment, Arrange, Wrap, and 

Anchor (both for images and drawing objects).  

2. From the pop-up menu displayed when you right-click on the graphic.  

3. From the Object toolbar shown in Figure 1.11.  

4. For images, from the Type and Wrapping pages of the Picture dialog box. Note 

that you cannot control the arrangement using the dialog box. To open the 

Picture dialog box, click on the image to select it and then choose Format > 

Picture or right-click on the graphic and choose Picture on the pop-up menu.  

5. For drawing objects, from the Position and Size page of the Position and Size 

dialog box. To open the Position and Size dialog box, click on the drawing 

object to select it and then choose Format > Object > Position and Size or right-
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click on the graphic and choose Position and Size on the pop-up menu. Note 

that you can only control the alignment and anchoring.  

 

Figure 1.11. Object toolbar (graphical control of positioning for images) 

ACTIVITY 

1. Create a New Year card using images 

2. Create a Poster on Health and Hygiene 

QUESTIONS 

1. Explain any four Graphic filters. 

2. Explain Image Cropping 

3. List any three methods of inserting images in a text document.  

4. What do you understand by the terms:   

a. Text Wrapping  

b. Anchoring  

 

 

SESSION : 3     CREATE AND USE TEMPLATE  

Relevant Knowledge 

A template is a model that you use to create other documents. For example, you can 

create a template for business reports that has your company’s logo on the first page. 

New documents created from this template will all have your company’s logo on the 

first page.  



23 | P a g e  

 

Templates can contain anything that regular documents can contain, such as text, 

graphics, a set of styles, and user-specific setup information such as measurement 

units, language, the default printer, and toolbar and menu customization.  

All documents in OpenOffice.org are based on templates. You can create a specific 

template for any document type (text, spreadsheet, drawing, presentation). If you do 

not specify a template when you start a new document, then the document is based on 

the default template for that type of document.  If you have not specified a default 

template, Open Office uses the blank template for that type of document that is 

installed with Open Office.  

Creating a Template  

You can create your own templates in two ways: from a document, and using a wizard.  

Creating A Template From A Document  

To create a template from a document:  

1. Open a new or existing document of the type you want to make into a template 

(text document, spreadsheet, drawing, presentation).  

2. Add the content and styles that you want.  

3. From the main menu, choose  

File > Templates > Save.  
 

Template Dialog 

 

 

 

 

 

 

 
 

Figure 1.12: Saving a new template 

The Templates dialog opens (see Figure 1.12).  



24 | P a g e  

 

1. In the New template field, type a name for the new template.  

2. In the Categories list, click the category to which you want to assign the template. 

The category you choose has no effect on the template itself; it is simply the 

folder in which you save the template. Choosing an appropriate category makes 

it easier to find the template when you want to use it. For example, you might 

save Impress templates under the Presentations category.  

3. Click OK to save the new template.  

Any settings that can be added to or modified in a document can be saved in a template. 

For example, below are some of the settings that can be included in a Writer document 

and then saved as a template for later use:  

1. Printer settings: which printer, single sided / double sided, and paper size, and so 

on  

2. Styles to be used, including character, page, frame, numbering and paragraph 

styles  

3. Format and settings regarding indexes, tables, bibliographies, table of contents  

Templates can also contain predefined text, saving you from having to type it every 

time you create a new document. For example, a letter template may contain your 

name, address and salutation.  

Creating A Template Using A Wizard  

You can use wizards to create templates for letters, faxes, agendas, presentations, and 

Web pages. For example, the Fax Wizard guides you through the following choices:  

1. Type of fax (business or personal)  

2. Document elements like the date, subject line (business fax), salutation, and 

complementary close  

3. Options for sender and recipient information (business fax)  

4. Text to include in the footer (business fax)  
 

Creating a template using a wizard: 

  

1. From the main menu, choose File > Wizards >[type of template required](see 

Figure 1.13).  
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                          Figure 1.13.  Creating a template using a wizard   

 

1. Follow the instructions on the pages of the wizard. This process is slightly 

different for each type of template, but the format is very similar. 

2. In the last section of the wizard, you can specify the name and location for saving 

the template. The default location is your user templates directory, but you can 

choose a different location if you prefer.  

3. Finally, you have the option of creating a new document from your template 

immediately, or manually changing the template. For future documents, you can 

reuse the template created by the wizard, just as you would use any other 

template.  
 

Setting A Default Template  

If you create a document by choosing File > New > Text Document (or Spreadsheet, 

Presentation, or Drawing) from the main menu, Open Office creates the document 

from the Default template for that type of document. You can, however, set a custom 

template to be the default. You can reset the default later if you choose.  

Setting a custom template as the default  

You can set any template to be the default, as long as it is in one of the folders displayed 

in the Template Management dialog.  
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To set a custom template as the default:  

1. From the main menu, choose File > Templates > Organize. The Template 

Management dialog opens.  

2. In the box on the left, select the folder containing the template that you want to 

set as the default, then select the template.  

3. Click the Commands button and choose Set As Default Template from the drop-

down menu.  

The next time that you create a document by choosing File > New, the document will 

be created from this template.  

Resetting the default template  

To re-enable Open Office’s Default template for a document type as the default:  

1. In the Template Management dialog, click any folder in the box on the left. 

2. Click the Commands button and choose Reset Default Template from the drop-

down menu.  

The next time that you create a document by choosing File > New, the document will 

be created from Open Office’s Default template for that document type.  

Using The Template  

To use a particular template, choose File > New > Templates and Documents. You'll 

see the templates window and your templates; if you don't, select the Templates icon 

at the left. 

                        

                                                 Figure 1.14.  Opening templates 
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Select the template you want. Any information about the template will be displayed. 

                                
                   Figure 1.15.  Using a template 

 

Double-click the template or click on open to open it. Now you can use the template 

according to your choice. 

 

Changing To A Different Template 

To change to a different template, choose File > New > Templates and Documents. 

You'll see the templates window and your templates; if you don't, select 

the Templates icon at the left. 

 

Figure 1.16.  Opening templates 
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Select the template you want. Any information about the template will be displayed. 

 
Figure 1.17.  Changing to a different template 

Double-click the template or click on open to open it. Now you can use the template 

according to your choice. 
 

Updating a Document 

To update a document simply goto File Save As and all changes made to the 

document will be saved. 

 

ACTIVITY 

Create your own template for any topic of your subject. 

 

QUESTIONS:  

1. What are templates? What are the advantages of using templates?  

2. What is the difference between styles and templates?  

3. Explain different ways of creating a template. 
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SESSION 4.   CREATE AND CUSTOMIZE TABLE OF CONTENTS  

 

Creating a Table of Contents 
 

Writer’s table of contents feature lets you build an automated table of contents from 

the headings in your document. Before you start, make sure that the headings are styled 

consistently. For example, you can use the Heading 1 style for chapter titles and 

the Heading 2 and Heading 3 styles for chapter subheadings. 

 

Opening Writer's Table Of Contents Feature 

Although tables of contents can be customized extensively in Writer, often the default 

settings are all you need. Creating a quick table of contents is simple: 

1. When you create your document, use the following paragraph styles for different 

heading levels (such as chapter and section headings): Heading 1, Heading 2, 

and Heading 3. These are what will appear in your table of contents. You can use 

more levels of headings, but the default setting is to use only the first three levels 

in the table of contents. 

2. Place the cursor where you want the table of contents to be inserted. 

3. Select Insert > Indexes and Tables > Indexes and Tables. 

4. Change nothing in the Insert Index/Table dialog. Click OK. 

 

If you add or delete text (so that headings move to different pages) or you add, delete, 

or change headings, you need to update the table of contents. To do this: 

 

1. Place the cursor within the table of contents. 

2. Right-click and select Update Index/Table from the pop-up menu. 
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Figure 1.14.  The Index/Table tab. 

 

Using the Index/Table tab 

Use the Index/Table tab, pictured in Illustration 1 on page 1, to set the table's 

attributes. 

Setting Basic Attributes 

To set the table's basic attributes: 

1. From the Type drop-down list in the Type and title area of the tab, select Table of 

Contents if it isn't already selected. 

2. From the drop-down list in the Create index/table area, select Entire document. 

3. In the Create from area, check the Outline check box. 

4. In the Create from area, clear the Index marks check box. 
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Adding A Title 

If you'd like the table of contents to have a title, enter it in the Title field. (If Writer 

entered a title in this field automatically, you can change it by simply typing over the 

value.) To delete the title, clear the Title field. 

Protecting Against Manual Changes 

To protect the table of contents from being changed accidentally, check the Protected 

against manual changes check box.  

If this box is checked, the table of contents can only be changed using the context menu 

or the Insert Table/Index window.  

If the box isn't checked, the table of contents can be changed directly on the document 

page, just like other text. 

Changing The Number Of Levels 

By default, Writer evaluates 10 levels of headings when it builds the table of contents.  

To change the number of levels evaluated, enter the desired number in the Evaluate up 

to level spin box. 

Assigning Custom Styles 

Writer automatically assigns to the table of contents all paragraphs formatted with the 

default heading styles (Heading 1, Heading 2, and so on). To assign paragraphs 

formatted with custom styles, follow these steps: 

1. In the Create from area, check the Additional Styles check box. 

2. Click the (...) button to the right of the check box. The Assign Styles window opens. 
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Figure 1.15.  Assign Styles window 

3. In the Not applied column, click the style that you want to assign to the table of 

contents. 

4. Use the >> button to move the selected style to the desired outline level. For 

example, if you want paragraphs formatted with the selected style to appear as top-

level entries in the table of contents, click the >> button once to move the style into 

the 1 column. To move the style in the opposite direction, use the << button. 

5. Click OK to save your changes and return to the Index/Table tab. Or, click Cancel 

to return without saving your changes. 

Using The Entries Tab 

Use the Entries tab, pictured in Illustration 3 on page 4, to format the entries in the 

table of contents. For each outline level, you can add and delete elements, such as 

chapter numbers, and you can also apply character styles to individual elements. 
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Figure 1.16.  Entries tab 

To begin, click a level number in the Level column to select the outline level whose 

elements you want to format. (You'll be able to apply your changes to all outline levels 

later.) The Structure line displays the elements for entries in that level. Each button on 

the Structure line represents one element: 

 The E# button represents the chapter number. 

 The E button represents the entry text.
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 The T button represents a tab stop. 

 The # button represents the page number. 

 The LS button represents the start of a hyperlink. (This button doesn't appear on the 

default Structure line.) 

 The LE button represents the end of a hyperlink. (This button doesn't appear on the 

default Structure line.) 

 

Each white field on the Structure line represents a blank space. 

Deleting Elements 

To delete an element from the Structure line, click the button that represents that element 

and then press the Delete key on your keyboard. For example, to delete a tab stop, click 

the T button and then press the Delete key. 

Adding Elements 

To add an element to the Structure line, follow these steps: 

1. Place your cursor in the white field to the left of where you want to insert the element. 

2. Click one of the five buttons that are just below the Structure line. (For example, to 

add a tab stop, click the Tab stop button.) A button representing the new element 

appears on the Structure line. 

Note that if you insert a hyperlink, you must indicate both the beginning and end of the 

link. For example, to change the default Structure line so that the chapter number and the 

entry text form a hyperlink, follow these steps: 

1. On the Structure line, place your cursor in the white field to the left of theE# button. 

(Recall that the E# button represents the chapter number.) 

2. Click the Hyperlink button. An LS button, representing the start of the hyperlink, 

appears on the Structure line. 

3. On the Structure line, place your cursor in the white field to the right of theE button. 

(Recall that the E button represents the entry text.) 

4. Click the Hyperlink button again. An LE button, representing the end of the hyperlink, 

appears on the Structure line. 
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Applying Character Styles 

To apply a character style to an element on the Structure line: 

1. On the Structure line, click the button that represents the element to which you want 

to apply a style. 

2. From the Character Style drop-down list, select the desired style. Writer applies the 

selected style to the selected element. 

To view or edit the attributes of a character style, select the style from the Character 

Style drop-down list and then click the Edit button. 

Applying Changes To All Outline Levels 

To apply the displayed structure and formatting to all outline levels, click the All button. 

Using The Styles Tab 

Use the Styles tab, pictured in Illustration 4 on page 6, to apply paragraph styles to the 

table of contents. You can apply a different paragraph style to each outline level of the 

table. 

 

Figure 1.17.  Styles tab 
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To apply a paragraph style to an outline level, follow these steps: 

1. In the Levels list box, select the desired outline level by clicking it. 

2. In the Paragraph Styles list box, click the paragraph style that you want to apply. 

3. Click the < button to apply the selected paragraph style to the selected outline level.  

 

To remove paragraph styling from an outline level: 

1) In the Levels list box, select the desired outline level by clicking it. 

2) Click the Default button. 

To view or edit the attributes of a paragraph style, click the style in the Paragraph Styles 

list box and then click the Edit button. 

Using The Background Tab 

Use the Background tab, pictured in Illustration 5 on page 7, to add color or a graphic to 

the table background. 

Adding Color 

To add color to the background of th 

e table of contents, simply click the desired color in the color grid. 

 

Figure 1.18.  Background tab 
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Adding A Graphic 

To add a graphic to the background of the table of contents, follow these steps: 

1. From the As drop-down list, select Graphic. The Background tab displays the graphics 

options. 

 

Figure 1.19.   Graphics options on the Background tab 

1. Click the Browse button. The Find Graphics window opens. 

2. Find the graphic file that you want to use and then click the Open button. The Find 

Graphics window closes and the selected graphic appears in the graphic preview box 

on the right-hand side of the Background tab. (If you don't see the graphic, check the 

Preview check box underneath the graphic preview box.) 

3. In the Type area of the Background tab, choose how you want the background graphic 

to appear: 

● To position the graphic in a specific location in the background, select Position and 

then click the desired location in the position grid. 

● To stretch the graphic so that it fills the entire background area, select Area. 

● To repeat the graphic across the entire background area, select Tile. 
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Deleting Color Or Graphics 

To delete color or graphics from the table background, follow these steps: 

1. From the As drop-down list, select Color. 

2. Click No Fill on the color grid. 

 

Saving The Table Of Contents  

To save the table of contents so that the table appears in your document, click OK.  The 

Insert Index/Table window closes and the table of contents appears in your document.  

 

Maintaining A Table Of Contents Editing A Table Of Contents  

To edit an existing table of contents:  

1. Click anywhere in the table of contents and then right click. The context menu 

appears.  

2. From the context menu, choose Edit Index/Table. The Insert Index/Table window 

opens and you can edit and save the table using the four tabs described in the previous 

chapter.  

 

Updating A Table Of Contents  

To update a document's table of contents when changes are made to the document:  

1. Click anywhere in the table of contents and then right click. The context menu 

appears.  

2. From the context menu, choose Update Index/Table. Writer updates the table of 

contents to reflect the changes in the document.  

 

Deleting A Table Of Contents 

To delete the table of contents from a document:  

1. Click anywhere in the table of contents and then right click. The context menu 

appears.  

2. From the context menu, choose Delete Index/Table. Writer deletes the table of 

contents.  
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Note: Writer won't prompt you to confirm the delete! Use caution when deleting a table 

of contents. 

ACTIVITY 

Create a table of contents for topics of any subject of your choice. 

QUESTIONS:  

1. Create table of contents for your project.  

2. Create a document in Word on a topic of your choice of minimum 10 pages.  

Format the document with various fonts (minimum 12, maximum 15) and margins 

(minimum 2, maximum 4).  

The document should include a)  A bulleted or numbered list  

b) A table containing relevant details  

c) A picture of lion using clip art gallery  

d) An example of word art  

e) A header with student name & date  

f) A footer with pagination Create a table of contents for this document.  

  

 

SESSION 5. IMPLEMENT MAIL MERGE    

 

Advance concept of mail merge in word processing 

A mail merge is a way to take a letter you’ve written and send it to a whole bunch of 

people, personalizing it with information about them so they might think that you typed 

that letter personally for them. A mail merge can also be a quick way to take a list of 

people’s mailing addresses and generate labels or envelopes with the address for a 

different person on each label or envelope. In short, it’s a way to be personal, yet efficient. 

It’s essential for any person or organization that has a lot of clients, partners, parents and 

children, or other people to communicate with. 

Create a Mail Merge Document: Letter 

1. Open a template, if you have one you want to use, or create a new Writer document. 
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2. Save the document with the appropriate name, like mailmerge_openenrollment.ods or 

mailmerge_parents.odt. 

Note: Don’t save it in Word format. You must save it in OpenOffice.org Writer format or 

the mail merge won’t work. 

3. Write out the text that will be going to everyone, and plan where you want the fields. 

For instance, you might know that you are going to have an address block at the top of 

the letter, so you’ll leave a few blank lines for that. Then you’d write something like this, 

know that you’d add the fields firstname and years_of_service later: 

 

Dear , 

Remember that next month is open enrollment for benefits. Employees with over five 

years of experience are also eligible for sabbatical; you have been with us for years so 

please get your application in early if you plan to apply. 

Regards, 

Human Resources 

 

If you’re doing anything complex and this is your first mail merge letter, write out the 

letter completely as you want it to read including sample data. Use all the text, including 

samples for firstname, lastname, etc. This will help you determine which fields you need 

to use, where you need spaces before and after fields, etc. 

In the following example, for instance, if you want to communicate this, you’ll need to 

use fields from the database for title, lastname, childs_name, study_area, and test_score. 

 

 

Dear Ms. Smithson, 

Your child Jenny is such a joy to have in the classroom. Her score on her Social Studies 

test score last Friday was A-. 

Regards, 

Mr. Thomson 
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4. Once you have the letter written out and you know what fields you need, you can delete 

the specific data like “Ms. Smithson” and insert the fields from the database instead. 

 

To Make The Data Source And Entering Data 

OpenOffice.org is set up with a middle-man file in the mail merge process to make 

merging work easily. You’ll create a small file, one for each spreadsheet or other data 

source. Once you create it, you don’t have to do it again. 

1. Choose File > New > Database. You’ll see this window: 

 

Figure 1.20 : Database Wizard 
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3. Select the type of data: spreadsheet data, text file data, your particular type of 

address book, or the type of database you’re using like Access or mySQL. It’s very 

important to select the right type. 

 

 

Figure 1.21 : Selecting the database type in Database Wizard 

 

3. Click Next. 

4. What you do here depends on what you chose as the type of data you’re working with. 

 

Spreadsheet 

You’ll see this window. Click the Browse button and find the spreadsheet containing your 

data. Then click Next and continue to step 5. 
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Figure 1.22 : Selecting the spreadsheet in Database Wizard 

Text File 

You’ll see this window. Click the Browse button and find the directory containing your 

text files. 

 

Figure 1.23: Selecting the text file in Database Wizard 
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Fill out the rest of the information: 

Specify the type of files you want to access: Specify whether the file name ends in .txt 

or .csv. 

Row format: In the Field Separator list, specify what character separates each column: a 

tab, a comma, etc. Tab and comma are common. In the other lists, if 11111you don’t 

know the characters used to indicate each type of information, just leave the defaults as 

is. 

Then click Next and continue to step 5. 

Access 

You’ll see this window. Click the Browse button and find the .mdb Access file containing 

your data. Then click Next and continue to step 5. 

 

Figure 1.24 : Selecting the Access database in Database Wizard 
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Address book 

You don’t have to specify anything if you choose to get your data from your email address 

book; the system automatically finds it. Continue to step 5. 

5. In this window, just be sure to keep the option for registering selected. Unmark the 

selection to open the database for editing unless you want to see the database editing 

window. (You don’t need to unless you want to make a query or other database-related 

item, which we haven’t talked about yet.) 

 

Figure 1.25 : Deciding how to proceed after saving the database in Database Wizard 

Click Finish. 

6. You’ll be prompted to save the database file. Name it something very descriptive; this 

is the name you’ll be looking for when you’re adding database files to your mail merge 

documents. The name can be the same as the data source that you’re basing it on, or 

entirely different. The file will end in .odb and be stored in whatever directory you 

choose. It doesn’t have to be in the same directory as the data. 
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Figure 1.26 : Saving the database 

7. You can see your databases by pressing F4 when you’re in a Writer or Calc document. 

Click the + icon next to the database you created to see the items named Queries and 

Tables. Click the + next to Tables to see the tables you created; select a table to see the 

data in it. 

Figure 1.27 :Viewing the content in selected table 

 

When you’re done viewing your databases, press F4 again to hide the pane. 
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You’re done creating the database file. You only need to do this once for every 

spreadsheet, database, or directory of text files. 

 

Merging The Data Source With Main Document 

1. Open the letter you want to use. 

2. Once you have the letter written out and you know what fields you need, you can 

delete the specific data like “Ms. Smithson” and insert the fields from the database 

instead. 

Press F4. Click the + next to the database you want, then click the + next to Tables and 

the + next to the table you want. 

 

Figure 1.28 :Viewing the content in selected table 

3. Now just drag the field you want into the letter, to the place you want it. 

a. Click and hold down on the name of the first field you want. Don’t click on the data, like 

Smithson; click on the name of the field, like lastname. 

 
Figure 1.29 : Selecting the field to insert in the document 
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b. Drag the field name into the letter to the place where you want it. The mouse will have 

a + attached to it as shown. 

 
c. Release the mouse. The field will appear. You won’t see the data yet; you’ll see the 

field name. 

 
 

4. If you didn’t get it exactly where you want it, just select it, and cut and paste it to 

the place where you want it. The easiest way to select a field is to click on the right side 

of it, hold down the Shift key, and press the left keyboard key once. Then it’s selected 

and you can cut or copy. 

5. Drag in all the other fields you want, the same way. If you want a field in the letter 

twice, you can drag it twice, or drag it in once, then copy and paste it to the other location. 

6. The fields should display with a gray background, as shown. It won’t print; it just 

helps you see which text is from the database and which text you typed. 

7. Format the document any way you want it. The fields respond to formatting the 

same way that normal text does. 

8. You’re done creating the mail merge document. You only need to do this once. The 

next step is to either print the letter to a printer, or “print” to a Writer file so you can see 

all the data merged, and so you can customize, before printing on paper. Continue to the 

printing step. 

Editing a saved file of mailing labels  

To edit a saved file of mailing labels, open the saved label file in the normal way. You 

will be prompted to update all links. Choose No for the following reason: The first label 

on the page is termed the “Master Label” and all other labels are linked to it. If you update 

the links, then all labels will end up containing the same data, which is probably not what 

you want. You can edit individual records in the normal way, by highlighting and 

changing the font name, for example.  
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However, you cannot edit all labels globally (for example, to change the font name for all 

records) by the technique of selecting the entire document. To achieve this result you have 

to edit the paragraph style associated with the label records as follows.  

 

● Right-click any correctly spelled word in a label record.  

- Select Edit Paragraph Style from the context menu. (Note: If you click on a misspelled 

word, a different menu appears.) 

- Then from the Paragraph Style dialog, you can make changes to the font name, the font 

size, the indents, and other attributes.  

 

Printing Mailing Labels  

Before beginning this process, note the brand and type of labels you intend to use.  

 

Preparing For Printing  

To prepare mailing labels for printing:  

● Choose File > New > Labels.  

● On the Options tab, ensure that the Synchronize contents option is selected. ● On 

the Labels tab (), select the Database and Table. Select the Brand of labels to be used, 

and then select the Type of label.  

● If you are unable to identify your label product in the list, then you can define the labels 

you have. Select the User setting in the Type selection box. Click on the Format tab of 

the Labels dialog. The default settings are shown in . Take a ruler and measure on your 

labels those dimensions illustrated in , and enter them into the respective boxes on the left 

side.  

 

Figure 1.30 : Required information for label set-up 
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Figure 1.31: Select Database, Table, label Brand, and label Type 

 

 

Figure 1.32: User label default settings 
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● You can now save your label template if you are likely to use it again. Click Save. 

● In the Save Label Format dialog that opens (), enter names for your label Brand 

and Type. Click OK.  

 

 

Figure 1.33: Name and save the label. 

● Click the Labels tab. Click the drop-down arrow under Database field. Select the 

first field to be used in the label (in this example, Title). Click the left arrow button to 

move this field to the Label text area, as shown in Figure.  

 

 

Figure 1.34: Move fields from Database field list to Label text area 

● Continue adding fields and inserting desired punctuation, spaces, and line breaks 

until the label is composed. shows the completed label.  
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Figure 1.35: The completed label 

● Click New Document. You now have a new, single-page document containing a series 

of frames, one for each label of the selected type and filled with the data source address 

fields that you selected. Quite often some of the fields in your address data source will be 

unused, leading to blank lines in your labels. If this is not important, go to “” on page; 

otherwise, continue with “”.  

 

Removing Blank Lines From Labels  

● First ensure that the label frames are showing the field contents (data source 

headings), rather than their underlying field names. If this is not the case, then either press 

Ctrl+F9 or choose View > Field Names to toggle the view.  

● Next, ensure that you can see non-printing characters, such as paragraph marks, 

line breaks and so on. If these are not already visible, choose View > Nonprinting 

Characters from the Menu bar, or press Ctrl+F10, or click on the Nonprinting 

Characters icon ( ) on the Standard toolbar.  
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You will now see that address field separation is created by line breaks ( ), rather than 

paragraphs ( ). As the suppression of blank address fields depends on hiding paragraphs, 

not lines, you need to replace line breaks with paragraphs as follows.  

● Click in the first label, at the end of the last data source address field in the first 

line of the label. Press Delete to remove the new line character and then press Return (or 

the Enter key) to insert a paragraph marker. Repeat this action for each line in the address. 

If the line spacing in the first label is not satisfactory, you may wish to correct this before 

proceeding, by modifying the paragraph style associated with the address.  

Unless you have changed it, the address uses the Default style.  

 

Note: The objective of step 3) is to replace all line breaks at the end of data source address 

fields with paragraphs. Sometimes the address data field may be longer than the width of 

the label and will wrap to the next physical line: make sure that you are not misled by this 

into deleting and replacing anything other than line break characters. 

 

● Click again at the end of the first paragraph to be conditionally suppressed and then 

choose Insert > Fields > Other. Select the Functions tab and then click on Hidden 

Paragraph in the Type column. Now click in the Condition box and enter the details of 

the condition that defines a blank address field. It has the general form of:  

 ![Database.Table.Database field] where the „!‟ (NOT) character indicates the negative 

case and the square brackets indicate the condition.  

For example, in our Points database the condition to test if the Last Name field is empty 

would be   

  ![Points.Sheet1.Last Name] as illustrated in .  

To test for multiple conditions, use the operators AND and/or OR between the conditional 

statements, for example:  

  ![Points.Sheet1.Title]AND![Points.Sheet1.Last Name]  

Click Insert, but do not close the dialog until all lines have been amended.  

● Repeat for each paragraph to be conditionally suppressed, remembering to advance 

the cursor to the end of the line in question before changing the last element of the 

condition and Inserting the result.  

  

Note: The last paragraph of the label address block ends with a special field, Next record: 

Database. Table (Next record: Points.Sheet1in our example), and the Hidden paragraph 
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field must be inserted before this field. This can generally be accomplished by clicking at 

the end of the paragraph and then using the Left Arrowkey once to skip back over it. A 

clue that you omitted this action is the observation that some records have been skipped 

and are missing from the final output. 

 

 

● Remembering that we selected Synchronize contents earlier, you should now be 

able to see a small window containing a Synchronize Labels button. Click on this button 

and the hidden paragraph fields are propagated to all the labels in your document.  

You now have a template suitable for future use with the same data source and type of 

label. If you wish to save it, use File > Templates > Save as Template to save it as an 

Open Document Text Template (.ott) into the My Templates folder in the Templates 

Manager dialog.  

 

Printing  

● Choose File > Print. The message shown in appears. Click Yes to print.  

● In the Mail Merge dialog (), you can choose to print all records or selected records. 

To select records to be printed, use Ctrl+click to select individual records. To select 

a block of records, select the first record in the block, scroll to the last record in the 

block, and Shift+click on the last record.  

● Click OK to send the labels directly to the printer.  

If you prefer to save the labels to a file, perhaps to allow some later editing such as 

changing the typeface or paragraph format, then you should select File in the output 

section of the Mail Merge dialog, rather than using the default Printer selection. This 

changes the dialog to highlight the Save merged document section, where Save as single 

document is preselected.  

In this case, clicking OK brings up the Save as dialog, where a file name can be entered 

for the saved labels.  

If you did not save the prototype label fields document (template) in Step 6 of the 

Removing blank lines from documents paragraph, then you are prompted to do so now by 

another Save as dialog.  
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In either case, whether printing or saving to file, despite there apparently being only one 

page of labels, the printed or saved output will be expanded to include all of the selected 

records from the data source.  

 

Printing to a File for Previewing or Customizing Before Printing on Paper 
 

To print to a file – that is, to just generate a Writer document with the merged results – 

select File and Save as Single Document. Then click OK. 

 

 
Figure 1.36: Mail Merge Dialog box 

You’ll be asked to give a file name. This is the name of the merged document. Name it 

and click Save. 
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Figure 1.37: Saving the merged document 

You’ll see the print monitor counting through the records. 

 
 

Now choose File > Open and open that file you just named. 

Note: When you open the output from merged labels, don’t click yes when you see this 

message. Click No. If you click Yes accidentally, just close it without saving, and 

reopening it, clicking No this time. 

 

 
You’ll see the merged results. 

Here’s one example of a merged letter: 
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Figure 1.38: The merged document 

And merged labels: 

 
Figure 1.39: The merged labels 
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At this point you can view the document and proof it, make any changes you want, and 

save it. Then to print it, just print it like a normal document, since it’s already merged 

with the data from the database. 

 

ACTIVITY 

1. Type a letter inviting friends and/or family to a party you are hosting. For example, 

you can host a birthday party or your parents‟ anniversary party. You pick the event. 

Your letter will serve as your form letter. Save your letter as Mail Merge Letter.  

2. Format the letter as left aligned (block letter) with .5” or 1” margins depending on 

the length.  

3. Make sure your address is listed at the top of the document. Then insert two blank 

lines and put the date in the month, date, year format. Then enter four blank lines 

and leave space for your merge fields. Example:  

Title First Name Last  

Name Address 1  

Address 2 City,  

State Pin Code  

(Eventually you will be entering your merge fields to replace this information.)  

4. Create a data source with the names and addresses of at least five families in which 

you wish to mail the letters. Create fields such as: title, first name, last name, address 

1, address 2, city, state, and pin code. Or make appropriate field names of your 

choice but make sure you include the address information. Save your data source as 

Mail Merge Data.  

5. Now, return to your main document (Mail Merge Letter) and set it as the form 

document and identify your data source.  

6. Enter your merge fields into your main document. Merge fields should be used for 

the recipients address and after Dear.  

7. After your merge fields are entered merge the document and save it. Save the 

merged document as Mail Merge Merged.  

8. Create labels inserting your merge fields for the recipient’s name and address. Save 

the merged labels as Mail Merge Labels.  

9. Print your form letter, one merged letter, and one label.  
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Let's Practice  

Open the Word Processing software and prepare the following labels for  

• Schools to invite parents for annual function  

• A Tech Magazine who wants to send flyers to its clients   

 

QUESTIONS 

1. Explain Mail Merge. 

2. What are advantages of Mail Merge? 

3. Give examples of databases in which the Data Source can be created. 

. 
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SESSION 1: ANALYZE DATA USING SCENARIOS AND GOAL SEEK 

Consolidating data 

Data Consolidation allows you to gather together your data from separate worksheets into 

a master worksheet. In other words, the Data Consolidation function takes data from a 

series of worksheets or workbooks and summaries it into a single worksheet that you can 

update easily. 

1) Open the worksheet that contains the cell ranges to be consolidated. 

2) Choose the Consolidate option under the Data menu as shown in Figure2.1. The 

Consolidate dialog box is shown in Figure 2.2. 

 
Figure 2.1: Consolidate option under Data Menu 

 

 
      Figure 2.2: Consolidate Dialog box defining the data to be consolidated 
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3) If the Source data range list contains named ranges, you can select a source cell 

range to consolidate with other areas. 

If the source range is not named, click in the field to the right and either type a 

reference for the first source data range or use the mouse to select the range on the 

sheet. (You may need to move the Consolidate dialog to reach the required cells.) 

4) Click Add. The selected range now appears on the Consolidation ranges list. 

5) Select additional ranges and click Add after each selection. 

6) Specify where you want to display the result by selecting a target range from the Copy 

results to box. 

If the target range is not named, click in the field next to Copy results to and enter 

the reference of the target range or select the range using the mouse or position the 

cursor in the top left cell of the target range. 

7) Select a function from the Function list. The function specifies how the values of the 

consolidation ranges are linked. The Sum function is the default setting. 

Most of the available functions are statistical (such as AVERAGE, MIN, MAX, 

STDEV), and the tool is most useful when you are working with the same data over 

and over. 

8) Optionally click More in the Consolidate dialog to display additional settings. 

• Select Link to source data to insert the formulas. This generates the results in the 

target range instead of the actual results. If you link the data, any values modified in 

the source range are automatically updated in the target range. The corresponding cell 

references in the target range are inserted in consecutive rows, which are 

automatically ordered and then hidden from view. Only the final result, based on the 

selected function, is displayed. 

• Under Consolidate by setting, select either Row labels or Column labels, if the cells 

of the source data range are not to be consolidated corresponding to the identical 

position of the cell in the range, but instead according to a matching row label or 

column label. To consolidate by row labels or column labels, the label must be 

contained in the selected source ranges. The text in the labels must be identical, so 

that rows or columns can be accurately matched. If the row or column label does not 

match any that exist in the target range, it will be appended as a new row or column. 

9) Click OK to consolidate the ranges. 

10) If you are continually working with the same range, then you probably want to use 

Data > Define Range to give it a name. Define Range option is available under the 

Data Menu. 
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The data from the consolidation ranges and target range are saved when you save the 

worksheet. If you later open a worksheet in which consolidation has been defined, 

this data will again be available. 

 

Creating Subtotals 

SUBTOTAL is a function listed under the Mathematical category when you use the 

Function Wizard (Insert > Function). Because of its usefulness, the function has a 

graphical interface. It is accessible from Data menu as shown in Figure2.3.   

 

 

Figure 2.3: Subtotal option under Data Menu 

SUBTOTAL, totals/adds data arranged in an array—that is, a group of cells with labels 

for columns and/or rows. Using the Subtotals dialog, you can select arrays, and then 

choose a statistical function to apply to them. For efficiency, you can choose up to three 

groups of arrays to which to apply a function. When you click OK, Calc adds subtotals 

and grand totals to the selected arrays, using the Result and Result2 cell styles for them. 

Steps to insert subtotal values into a sheet: 

1) Ensure that the columns have labels. 

2) Select the range of cells that you want to calculate subtotals for, and then choose Data 

-> Subtotals. 

3) In the Subtotals dialog (Figure 2.4), in the Group by box, select the column that you 

want to add the subtotals to. If the contents of the selected column change, the 

subtotals are automatically recalculated. 

4) In the Calculate subtotals for box, select the columns containing the values that you 
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want to subtotal. 

5) In the Use function box, select the function that you want to use to calculate the 

subtotals. 

6) Click OK. 

 
Figure 2.4: Setting up subtotals 

If you use more than one group, then you can also arrange the subtotals according to 

choices made on the dialog‘s Options page (Figure 2.5), including ascending and 

descending order or using one of the predefined custom sorts defined under Tools menu 

as Tools-> Options-> OpenOffice.org Calc-> Sort Lists. 
 

 
Figure 2.5: Choosing options for subtotals 
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Using “What If” Scenarios 

Scenarios are a tool to test “what-if” questions. Each scenario is named, and can be edited 

and formatted separately. When you print the spreadsheet, only the content of the 

currently active scenario is printed. 

A scenario is essentially a saved set of cell values for your calculations. You can easily 

switch between these sets using the Navigator or a drop-down list which can be shown 

beside the changing cells. For example, if you wanted to calculate the effect of different 

interest rates on an investment, you could add a scenario for each interest rate, and quickly 

view the results. Formulas that rely on the values changed by your scenario are updated 

when the scenario is opened. If all your sources of income used scenarios, you could 

efficiently build a complex model of your possible income. 

 

Creating Scenarios 

Use Scenarios option under Tools menu to enter variable contents—scenarios—in the 

same cell.  To create a scenario: 

1) Select the cells that contain the values that will change between scenarios. To select 

multiple cells, hold down the Ctrl key as you click each cell. 

2) Choose Tools > Scenarios. 

3) On the Create Scenario dialog (Figure 2.6), enter a name for the new scenario. It‘s 

best to use a name that clearly identifies the scenario, not the default name as shown 

in the illustration. This name is displayed in the Navigator and on the title bar of the 

scenario on the sheet itself. 

 
Figure 2.6: Creating a scenario 
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4) Optionally add some information to the Comment box. The example shows the 

default comment. This information is displayed in the Navigator when you click the 

Scenarios icon and select the desired scenario. 

5) Optionally select or deselect the options in the Settings section. See below for more 

information about these options. 

6) Click OK to close the dialog. The new scenario is automatically activated. 

You can create several scenarios for any given range of cells. 

 

Using Goal Seek 

Usually, you run a formula to calculate a result based upon existing values. By contrast, 

using Goal Seek option under Tools menu, you can discover what values will produce the 

result that you want. 

 

To take a simple example, imagine that the Chief Financial Officer of a company is 

developing sales projections for each quarter of the forthcoming year. She knows what 

the company’s total income must be for the year to satisfy stockholders. She also has a 

good idea of the company’s income in the first three quarters, because of the contracts 

that are already signed. For the fourth quarter, however, no definite income is available. 

So how much must the company earn in Q4 to reach its goal? The CFO can enter the 

projected earnings for each of the other three quarters along with a formula that totals all 

four quarters. Then she runs a goal seek on the empty cell for Q4 sales, and receives her 

answer. 

 

Other uses of goal seek may be more complicated, but the method remains the same. Only 

one argument can be altered in a single goal seek. 

 

Goal Seek example 

To calculate annual interest (I), create a table with the values for the capital (C), number 

of years (n), and interest rate (r). The formula is I = C*n*r. 

Let us assume that the interest rate r of 7.5% and the number of years n (1) will remain 

constant. However, you want to know how much the investment capital C would have to 

be modified in order to attain a particular return I. For this example, calculate how much 

capital C would be required if you want an annual return of $15,000. 

Enter each of the values mentioned above into adjacent cells (for Capital C, an arbitrary 

value like $100,000 or it can be left blank; for number of years n, 1; for interest rate r, 

7.5%). Enter the formula to calculate the interest I in another cell. Instead of C, n, and r 
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use the reference to the cell with the corresponding value. In our example, this would be 

=B1*B2*B3. 

1. Place the cursor in the formula cell (B4), and choose Tools > Goal Seek. 

2. On the Goal Seek dialog, the correct cell is already entered in the Formula cell field. 

3. Place the cursor in the Variable cell field. In the sheet, click in the cell that contains 

the value to be changed, in this example it is B1. 

4. Enter the desired result of the formula in the Target value field. In this example, the 

value is 15000. The figure below shows the cells and fields. 

 
Figure 2.7: Example setup for goal seek 

 

5. Click OK. A dialog appears informing you that the Goal Seek was successful. Click 

Yes to enter the result in the cell with the variable value. The result is shown below. 

 
Figure2.8: Result of goal seek operation 

 

Using the Solver 

Solver option under Tools menu amounts to a more elaborate form of Goal Seek. The 

difference is that the Solver deals with equations with multiple unknown variables. It is 
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specifically designed to minimize or maximize the result according to a set of rules that 

you define. 

Each of these rules sets up whether an argument in the formula should be greater than, 

lesser than, or equal to the value you enter. If you want the argument to remain unchanged, 

you enter a rule that the cell that contains it should be equal to its current entry. For 

arguments that you would like to change, you need to add two rules to define a range of 

possible values: the limiting conditions. For example, you can set the constraint that one 

of the variables or cells must not be bigger than another variable, or not bigger than a 

given value. You can also define the constraint that one or more variables must be integers 

(values without decimals), or binary values (where only 0 and 1 are allowed). 

Once you have finished setting up the rules, you can adjust the argument and the results 

by clicking the Solve button. 

 

Solver example 

 

Let's say you have $10,000 that you want to invest in two mutual funds for one year. Fund 

X is a low risk fund with 8% interest rate and Fund Y is a higher risk fund with 12% 

interest rate. How much money should be invested in each fund to earn a total interest of 

$1000? 

 

To find the answer using Solver: 

1. Enter labels and data: 

● Row labels: Fund X, Fund Y, and total, in cells A2 thru A4. 

● Column labels: interest earned, amount invested, interest rate, and time period, in 

cells B1 thru E1. 

● Interest rates: 8 and 12, in cells D2 and D3. 

● Time period: 1, in cells E2 and E3. 

● Total amount invested: 10000, in cell C4. 

2. Enter an arbitrary value (0 or leave blank) in cell C2 as amount invested in Fund X. 

3. Enter the formulae given below: 

● In cell C3, enter the formula C4-C2 (total amount - amount invested in Fund X) 

as the amount invested in Fund Y. 

● In cells B2 and B3, enter the formula for calculating the interest earned (see 

below). 

● In cell B4, enter the formula B2+B3 as the total interest earned. 
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Figure2.9: Example setup for solver 

 

4. Choose Tools -> Solver. The solver dialog opens as shown in Figure 2.10.

 
Figure2.10: The Solver dialog 

 

5. Click in the Target cell field. In the sheet, click in the cell that contains the target 

value. In this example it is cell B4 containing total interest value. 

6. Select Value of and enter 1000 in the field next to it. In this example, the target cell 

value is 1000 because your target is a total interest earned of $1000. Select Maximum 

or Minimum if the target cell value needs to be one of those extremes. 

7. Click in the By changing cells field and click on cell C2 in the sheet. In this example, 

you need to find the amount invested in Fund X (cell C2). 

8. Enter limiting conditions for the variables by selecting the Cell reference, Operator 
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and Value fields. In this example, the amount invested in Fund X (cell C2) should not 

be greater than the total amount available (cell C4) and should not be less than 0. 

9. Click OK. A dialog appears informing you that the Solving successfully finished. 

Click Keep Result to enter the result in the cell with the variable value. The result is 

shown below. 

 

 
Figure2.11: Result of Solver operation 

 

ACTIVITY/ QUESTIONS:  

1. A student is planning her goals about the marks she should attain in the forthcoming 

Semester 4 examinations in order to achieve a distinction (75%). Assuming that 

examination of each subject is for 100 marks, her marks of the previous semesters are 

given as under. 

 Subject 1 Subject 2 Subjec3 Subject 4 

Semester 1 82 67 53 87 

Semester 2 88 78 76 69 

Semester 3 89 85 91 67 

 

Find out how many marks should she obtain in 4th semester to secure distinction. 

2. A business owner wants to decide if he should try to increase the sales a product or 

price of an existing product in order to increase the profit by 10%. 

Current Sales 82 

Cost per Unit 75 

Profit per unit 12 
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The owner believes that he can either increase sales by 5 units without incurring 

additional costs while the price can be increased by Rs 8 without affecting the sales. 

 

3. The current profit situation of a business owner is as follows. 

Current Sales 82 

Cost per Unit 75 

Profit per unit 12 

 

Using the scenario manager, find the effect of in the new profit in case of the following 

situations. 

a. Sales = 70 and cost = 80 

b. Sales = 90 and cost = 72 

c. Sales = 85 and cost = 80 

d. Sales = 65 and cost = 80 

 

 

SESSION 2: LINK DATA AND SPREADSHEETS  
 

USING MULTIPLE WORKBOOKS AND LINKING CELLS  

 

Relevant Knowledge  

Spreadsheet also allows you to link the cells from various worksheets and from various 

other spreadsheets to summarize data from several sources. In this manner, you can create 

formulas that span different sources and make calculations using a combination of local 

and linked information. Multiple sheets help keep information organized 

 

SETTING UP MULTIPLE SHEETS  

Identifying sheets  

When you open a new spreadsheet, by default, it has a sheet named Sheet1 which is 

managed using tabs at the bottom of the spreadsheet, as shown below.   
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Figure 2.12 Identifying Sheets 

 

Inserting new sheets  

There are several ways to insert a new sheet. The first step, in all cases, is to select the 

sheet that will be next to the new sheet. Then do any of the following:   

 Select Insert > Sheet from the menu bar, or 

 Right-click on the tab and select Insert Sheet, or 

 Click in an empty space at the end of the line of sheet tabs. 

 

 
Figure2.13 Creating a new sheet 

Each method opens the Insert Sheet dialog. Here you can choose to put the new sheet 

before or after the selected sheet and how many sheets to insert. 

 

 
 Figure 2.13 Inserting New Sheets 

 

https://wiki.openoffice.org/wiki/File:CG3Ch9F1.png
https://wiki.openoffice.org/wiki/File:CG3Ch9F2.png
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Figure2.14 Insert Sheet dialog 

We need 6 sheets, one for each of the 5 accounts and one as a summary sheet so we will 

add 3 more. We also want to name each of these sheets for the account they represent: 

Summary, Checking Account, Savings Account, Credit Card 1, Credit Card 2, and Car 

Loan. 

We have two choices: insert 3 new sheets and rename all 6 sheets afterwards; or rename 

the existing sheets, then insert the three new sheets 1 at a time, renaming each new sheet 

during the insert step. 

To insert sheets and rename afterwards: 

1. In the Insert Sheet dialog, choose the position for the new sheets (in this example, we 

use After current sheet). 

2. Choose New sheet and 3 as the No. of sheets. (Three sheets are already provided by 

default.) Because you are inserting more than one sheet, the Name box is not 

available. 

3. Click OK to insert the sheets. 

4. For the next steps, go to “Renaming sheets” below. 

To insert sheets and name them at the same time: 

https://wiki.openoffice.org/wiki/File:InsertSheet3.png
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1. Rename the existing sheets Summary, Checking Account, and Savings Account, as 

described in “Renaming sheets” below. 

2. In the Insert Sheet dialog, choose the position for the first new sheet. 

3. Choose New sheet and 1 as the No. of sheets. The Name box is now available. 

4. In the Name box, type a name for this new sheet, for example Credit Card 1. 

5. Click OK to insert the sheet. 

6. Repeat steps 1–4 for each new sheet, giving them the names Credit Card 2 and Car 

Loan. 

On the Insert Sheet dialog, you can also add a sheet from a different spreadsheet file (for 

example, another Calc or Excel spreadsheet), by choosing the From file option. 

Click Browse and select the file; a list of the available sheets appears in the box. Select 

the sheet to import. If, after you select the file, no sheets appear you probably selected an 

invalid file type (not a spreadsheet, for example). 

 Note: For a shortcut to inserting a sheet from another file, choose Insert > Sheet from 

file from the menu bar. The Insert Sheet dialog opens with the From file option 

preselected, and then the Insert dialog opens on top of it. 

 

Inserting sheets from a different spreadsheet 

If you prefer, select the Link option to insert the external sheet as a link instead as a copy. 

This is one of several ways to include “live” data from another spreadsheet. The links can 

be updated manually to show the current contents of the external file; or, depending on 

the options you have selected in Tools > Options > OpenOffice.org Calc > General > 

Updating, whenever the file is opened. 

 

Renaming Worksheets 

At the bottom of each worksheet window is a small tab that indicates the name of the 

worksheets in the workbook. These names (Sheet1, Sheet2, Sheet3, and so on) are not 

very descriptive; you might want to rename your worksheets to reflect what they contain. 

For instance, if your workbook contains Students Marks in individual Subject then you 

may want to rename the worksheets as Subject names such as English, Mathematics and 

Social Science etc.  

There are three ways you can rename a worksheet, and the only difference between them 

is the way in which you start the renaming process. You can do any of the following:  
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• Double-click on one of the existing worksheet names.  

• Right-click on an existing worksheet name, then choose Rename from the resulting 

Context menu.  

• Select the worksheet you want to rename (click on the worksheet tab) and then select 

the Sheet option from the Format menu. This displays a submenu from which you 

should select the Rename option.  

Create Or Change A Cell Reference  

A cell reference refers to a cell or a range of cells on a worksheet and can be used to find 

the values or data that you want formula to calculate.  

In one or several formulas, you can use a cell reference to refer to:  

• Data from one or more contiguous cells on the worksheet.  

• Data contained in different areas of a worksheet.  

• Data on other worksheets in the same workbook.  

Referencing Other Sheets 

There are two ways to reference cells in other sheets: by entering the formula directly 

using the keyboard or by using the mouse. We will look at the mouse method first. 

Creating The Reference With The Mouse 

Look at the example below in Figure 2.14 which shows an account summary sheet with 

a blank Balance column. On the Summary sheet, set up a place for all five account 

balances, so we know where to put the cell reference. We want to place the reference for 

the checking account balance in cell B3. 

 
Figure 2.14 Blank summa 

To make the cell reference in cell B3, select the cell and follow these steps. 

https://wiki.openoffice.org/wiki/File:CG3Ch9F6.png
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1. Click on the = icon next to the formula bar. The icons change and an equals sign 

appears in the formula bars shown below. 

 
Figure 2.15 Equal sign in formula bar 

2. Now, click on the sheet tab for the sheet containing the cell to be referenced. In this 

case, that is the Checking Account sheet as shown below. 

 
Figure 2.16  the checking account tab 

3. Click on cell F3 (where the balance is) in the Checking Account sheet. The phrase 

‘Checking Account’.F3 should appear in the formula bar as shown below. 

 

 
Figure 2.17 Cell reference selected 

4. Click the green checkmark in the formula bar to finish. 

5. The Summary sheet should now look like the figure below. 

https://wiki.openoffice.org/wiki/File:CG3Ch9F7.png
https://wiki.openoffice.org/wiki/File:CG3Ch9F8.png
https://wiki.openoffice.org/wiki/File:CG3Ch9F9.png
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Figure 2.18. Finished checking account reference 

 

Creating The Reference With The Keyboard 

From the figure above, you can deduce how the cell reference is constructed. The 

reference has two parts: the sheet name (’Checking Account’) and the cell reference (F3). 

Notice that they are separated by a period. 

Note:The sheet will be in single quotes because it contains a space, and the mandatory 

period (.) always falls outside any quotes.   

 

So, you can fill in the Savings Account cell reference by just typing it in. Assuming that 

the balance is in the same cell in the Savings Account sheet, F3, the cell reference should 

be =’Savings Account’.F3. 

 
Figure2.19 Savings account reference 

https://wiki.openoffice.org/wiki/File:CG3Ch9F10.png
https://wiki.openoffice.org/wiki/File:CG3Ch9F11a.png
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Referencing Other Worksheets 

Calc can link different files together. The process is the same as described for different 

sheets in a single spreadsheet, but we add one more parameter to indicate which file the 

sheet is in. 

Creating The Reference With The Mouse 

To create the reference with the mouse, both spreadsheets need to be open. Select the cell 

in which the formula is going to be entered. 

1. Click the = icon next to the formula bar. 

2. Switch to the other spreadsheet (the process to do this will vary depending on which 

operating system you are using). 

3. Select the sheet (Savings account) and then the reference cell (F3). 

 

Figure 2.20 Selecting the savings account reference cell 

4. Switch back to the original spreadsheet. 

5. Click on the green check mark on the formula bar. 

Your spreadsheet should now resemble the figure below. 

 
Figure 2.21  Linked files 

https://wiki.openoffice.org/wiki/File:CG3Ch9F11b.png
https://wiki.openoffice.org/wiki/File:CG3Ch9F12.png
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You will get a good feel for the format of the reference if you look closely at the formula 

bar. Based on this line you can create the reference using the keyboard. 

Creating The Reference With The Keyboard 

Typing the reference is simple once you know the format the reference takes. The 

reference has three parts to it: 

 Path and file name 

 Sheet name 

 Cell 

Looking at the figure above, you can see the general format for the reference is 

=’file:///Path &File Name’#$SheetName.CellName. 

 

Working with Hyperlinks  

Hyperlinks can be used in Calc to jump to a different location from within a spreadsheet 

and can lead to other parts of the current file, to different files or even to web sites. 

 

Relative And Absolute Hyperlinks 

Hyperlinks can be stored within your file as either relative or absolute. 

An absolute link will stop working only if the target is moved. A relative link will stop 

working only if the start and target locations change relative to each other. For instance, 

if you have two spreadsheets in the same folder linked to each other and you move the 

entire folder to a new location, a relative hyperlink will not break. 

To change the way that OOo saves the hyperlinks in your file, select Tools > Options > 

Load/Save > General and choose if you want URLs saved relatively when referencing 

the File System, or the Internet, or both. 

You can insert and modify links using the Hyperlink dialog. To display the dialog, click 

the Hyperlink icon  on the Standard toolbar or choose Insert > Hyperlink from the 

menu bar. To turn existing text into a link, highlight it before opening the Hyperlink 

dialog. 

https://wiki.openoffice.org/wiki/File:HyperlinkIcon.png
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Figure 2.22 Hyperlink dialog showing details for Internet links 

On the left hand side, select one of the four types of hyperlinks: 

 Internet: the hyperlink points to a web address, normally starting with http:// 

 Mail & News: the hyperlink opens an email message that is pre-addressed to a particular 

recipient. 

 Document: the hyperlink points to a place in either the current worksheet or another 

existing worksheet. 

 New document: the hyperlink creates a new worksheet. 

The top right part of the dialog changes according to the choice made for the hyperlink 

category from the left panel. A full description of all the choices, and their interactions, 

is beyond the scope of this chapter. Here is a summary of the most common choices used 

in presentations. 

For an Internet hyperlink, choose the type of hyperlink (choose between Web, FTP or 

Telnet), and enter the required web address (URL). 

For a Mail and News hyperlink, specify whether it is a mail or news link, the receiver 

address and for email, also the subject. 
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For a Document hyperlink, specify the worksheet path (the Open File button opens a file 

browser); leave this blank if you want to link to a target in the same spreadsheet. 

Optionally specify the target in the worksheet (for example a specific sheet). Click on 

the Target icon to open the Navigator where you can select the target, or if you know the 

name of the target, you can type it into the box. 

For a New Document type hyperlink, specify whether to edit the newly created worksheet 

immediately (Edit now) or just create it (Edit later) and enter the file name and the type 

of worksheet to create (text, spreadsheet, etc.). The Select path button opens a directory 

picker dialog. 

The Further settings section in the bottom right part of the dialog is common to all the 

hyperlink types, although some choices are more relevant to some types of links. 

 Set the value of Frame to determine how the hyperlink will open. This applies to 

worksheets that open in a Web browser. 

 Form specifies if the link is to be presented as text or as a button. The figure below shows 

a link formatted as a button. 

 

Figure 2.23  Authors hyperlink as button 

 Text specifies the text that will be visible to the user. If you do not enter anything here, 

Calc will use the full URL or path as the link text. Note that if the link is relative and you 

move the file, this text will not change, though the target will. 

 Name is applicable to HTML documents. It specifies text that will be added as a NAME 

attribute in the HTML code behind the hyperlink. 

https://wiki.openoffice.org/wiki/File:CG3Ch9F15.png
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Linking To External Data 

You can insert tables from HTML documents, and data located within named ranges from 

an OpenOffice.org Calc or Microsoft Excel spreadsheet, into a Calc spreadsheet 

You can do this in two ways: using the External Data dialog or using the Navigator.   

 

Using the External Data dialog 

1. Open the Calc worksheet where the external data is to be inserted. This is the target 

worksheet. 

2. Select the cell where the upper left-hand cell of the external data is to be inserted. 

3. Choose Insert -> Link to External Data. 

4. On the External Data dialog, type the URL of the source worksheet or click the [...] button 

to open a file selection dialog. Press Enter to get Calc to load the list of available tables. 

5. In the Available tables/range list, select the named ranges or tables you want to insert. 

You can also specify that the ranges or tables are updated every (number of) seconds. 

6. Click OK to close this dialog and insert the linked data. 

 
Figure 2.24  Selecting a table or range in a source document from the Web 

https://wiki.openoffice.org/wiki/File:CG3Ch9F20.png
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Linking To Registered Data Sources 

You can access a variety of databases and other data sources and link them into Calc 

worksheets. First you need to register the data source with OpenOffice.org. (To register 

means to tell OOo what type of data source it is and where the file is located.) The way 

to do this depends on whether or not the data source is a database in *.odb format. 

To register a data source that is in *.odb format: 

1. Choose Tools -> Options -> OpenOffice.org Base -> Databases. 

2. Click the New button (below the list of registered databases) to open the Create 

Database Link dialog. 

 

Figure 2.25  Registering databases 

3. Enter the location of the database file, or click Browse to open a file browser and 

select the database file. 

https://wiki.openoffice.org/wiki/File:CG3Ch1-F22.png
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4. Type a name to use as the registered name for the database and click OK. The database 

is added to the list of registered databases. The OK button is enabled only when both 

fields are filled in. 

ACTIVITY 

Create a set of worksheets for storing records of marks of differnet classes and compare 

all these on a separate worksheet 

QUESTIONS: 

1. How can we rename a worksheet? 

2. What are the two ways of referencing cells in other worksheets? 

3. Differentiate between relative and absolute hyperlinks. 

4. List the procedure involved in Linking HTML Tables to Calc Worksheet 

5. Fill up the blanks 

a. At the bottom of each worksheet window is a small tab that indicates the ____________ 

of the worksheets in the workbook. 

b. A ___________ refers to a cell or a range of cells on a worksheet and can be used to find 

the values or data that you want formula to calculate. 

 

 

SESSION 3: SHARING WORKSHEET DATA  
 

Relevant Knowledge 

 

In most office settings, there is a shared drive where teams can store common files for 

everyone to use. This usually leads to sighting of the message: “The document [file name] 

is locked for editing by another user. To open a read-only copy of this document, click“!! 

This message appears because someone else already has the file open.  

Sometimes however, it is necessary to have multiple people working on a file at the same 

time. This can be to either speed up data entry or simply make things easier for 

collaboration purposes.  
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Spreadsheet software allows the user to share the workbook and place it in the network 

location where several users can access it simultaneously. 

In this exercise, you will learn how to share a worksheet in OpenOffice Calc.  

 

Setting Up A Spreadsheet For Sharing 

At any time, you can set up a spreadsheet for sharing with others. With the spreadsheet 

document open, choose Tools > Share Document to activate the collaboration features for 

this worksheet. A dialog opens where you can choose to enable or disable sharing. 

 

Figure 2.26  Choosing to share a spreadsheet 
 

To enable sharing, select the box at the top of the dialog, and then click OK. A message 

appears stating that you must save the worksheet to activate shared mode. Click Yes to 

continue. The word (shared) is then shown on the title bar after the worksheet's title. 

The Tools > Share Document command can be used to switch the mode for a worksheet 

from unshared to shared. However, if you want to use a shared worksheet in unshared 
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mode, you need to save the shared worksheet using another name or path. This creates a 

copy of the spreadsheet that is not shared. 

 

Opening A Shared Spreadsheet 

When you open a spreadsheet that is in shared mode, you see a message that the worksheet 

is in shared mode and that some features are not available in this mode. You can choose 

to disable this message for the future. After clicking OK, the worksheet is opened in 

shared mode. 

The following features are known to be disabled in a shared spreadsheet: 

● Edit > Changes, except for Merge Document 

● Edit > Compare Document 

● Edit > Sheet > Move/Copy & Delete 

● Insert > Cells Shift Cells Down & Shift Cells Right 

● Insert > Sheet from file 

● Insert > Names 

● Insert > Comment 

● Insert > Picture > From File 

● Insert > Movie and Sound 

● Insert > Object 

● Insert > Chart 

● Insert > Floating Frame 

● Format > Sheet > Rename, Tab Color 

● Format > Merge Cells > Merge and Center, Merge Cells, Split Cells 

● Format > Print Ranges 

● Tools > Protect Document 

● Data > Define Range 

● Data > Sort 

● Data > Subtotals 

● Data > Validity 

● Data > Multiple Operations 

● Data > Consolidate 

● Data > Group and Outline (all) 

● Data >DataPilot 
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Saving A Shared Spreadsheet 

When you save a shared spreadsheet, one of several situations may occur: 

● If the worksheet was not modified and saved by another user since you opened it, the 

worksheet is saved. 

● If the worksheet was modified and saved by another user since you opened it, one of 

the following events will occur: 

● If the changes do not conflict, the worksheet is saved, the dialog below appears, and 

any cells modified by the other user are shown with a red border. 

 
Figure 2.27  Update message after saving 

 

● If the changes conflict, the Resolve Conflicts dialog is shown. You must decide for 

each conflict which version to keep, yours or the other person’s. When all conflicts 

are resolved, the worksheet is saved. While you are resolving the conflicts, no other 

user can save the shared worksheet. 

 
 Figure 2.28   Resolve Conflicts dialog 
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● If another user is trying to save the shared worksheet and resolve conflicts, you see a 

message that the shared spreadsheet file is locked due to a merge-in in progress. You can 

choose to cancel the Save command for now, or retry saving later. 

When you successfully save a shared spreadsheet, the worksheet shows the latest version 

of all changes that got saved by all users. 

Note: Most spreadsheets software automatically turns off some features in shared 

workbooks. This is to simplify the workbook since multiple people can be working on the 

file at the same time. For example, shared workbooks don‘t allow merging cells, 

conditional formatting, or inserting pictures/graphs/etc.  

Perform the following activity till you are confident:  

S.No.  Activity  

1.  Share worksheet data with other users.  

 

Record Changes 

Calc has the feature to track what data was changed, when the change was made, who 

made the change and in which cell the change has  occurred. 

If you are the sponsor of a youth baseball team. The coach has submitted a budget to you 

for the season and you need to edit the costs and return it to her. You are concerned that 

if you just make the changes, then the coach won't see the changes you made. You decide 

to use Calc with the record changes feature turned on, so that the coach can easily see the 

changes you have made. 

The figure below shows the budget spreadsheet your coach submitted. 

 

Figure 2.29   Baseball budget spreadsheet  
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Looking Over The Values, 

You see a few places where money could be saved: 

● Post-game snacks can be bought by parents. 

● New uniforms can wait; only buy 10 to replace damaged ones. 

● Buy cheaper baseballs. 

● Only buy 2 spare gloves. 

To make these changes, use the record changes feature in Calc. To start recording 

changes: 

1. Open the Budget Spreadsheet. 

2. Select Edit > Changes > Record from the menu bar. 

3. Begin editing the worksheet. 

A colored border, with a dot in the upper left-hand corner, appears around a cell 

where changes were made. Other reviewers then quickly know which cells were 

edited. A deleted column or row is marked by a heavy colored bar. 

 

Figure 2.30  Edited worksheet with red border on changed cells 
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Some changes, for example cell formatting, are not recorded and marked. 

To change the color that indicates changes, select Tools > Options > OpenOffice.org 

Calc > Changes. 

Viewing Changes 

Calc gives you tremendous control over what changes you see when reviewing a 

worksheet. To change the available filters, select Edit > Changes > Show. The following 

dialog opens. 

  

Figure 2.31  Show changes dialog 

Using the different settings, you can control which changes appear on screen. You can 

filter based on: 

● Date – Only changes made in a certain time range are displayed. 

● Author – Only changes made by a specific author are displayed. This is especially useful 

if you have multiple reviewers on the worksheet. 

● Range – Only changes made in a specific range of cells are displayed. This is especially 

useful if you have a large spreadsheet and only want to review a part of it. 

● Comment – Searches the content of the comments and only displays changes which have 

comments that match the search criteria. 
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● Show accepted changes – Only changes you accepted are displayed. 

● Show rejected changes – Only changes you rejected are displayed. 

You can also access the filter control in the Accept or Reject Changes dialog shown 

below. Click the Filter tab to get a set of options similar to those shown in the figure 

above. 

Adding Comments to Changes 

Calc automatically adds to any recorded change a comment describing what was changed 

(for example, Cell B4 changed from ‘9’ to ‘4’). Reviewers and authors can add their 

comments to explain their changes. 

To add a comment to a change: 

1. Make the change to the spreadsheet. 

2. Select the cell with the change. 

3. Choose Edit > Changes > Comments. The dialog shown below appears. The 

automatically-added comment provided by Calc appears in the title bar of this dialog and 

cannot be edited. 

4. Type your own comment and click OK. 

 

 

Figure 2.32  Comment dialog 

After you have added a comment to a changed cell, you can see it by hovering the mouse 

pointer over the cell. 
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Figure 2.33 Comment added to cell B3 

The comment also appears in the dialog when you are accepting and rejecting changes. 

Editing change comments 

1. Select the cell with the comment that you want to edit. 

2. Select Edit > Changes > Comments. 

3. Edit the comment and click OK. 

 

Accepting or Rejecting Changes 

When you receive a worksheet back with changes, the beauty of the recording changes 

system becomes evident. Now, as the original author, you can step through each change 

and decide how to proceed. To begin this process: 

1. Open the edited worksheet. 

2. Select Edit > Changes > Accept or Reject. The dialog shown below opens. 

3. Calc steps through the changes one at a time. You can choose to accept or reject each 

change as you go through. 

 

Figure 2.34 Accept or Reject Changes dialog 
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The Comment column by default contains an explanation of the change that was made. If 

the reviewer added a comment to the change, it is displayed, followed by the description 

of the change. 

If more than one person has reviewed the worksheet, one reviewer may have modified 

another reviewer’s change. If so, the changes are hierarchically arranged with a plus sign 

for opening up the hierarchy. 

On the Filter tab of this dialog (not shown here), you can choose how to filter the list of 

changes: by date, author, cell range, or comments containing specific terms. After 

selecting the filter criteria, switch back to the List tab to see the results. 

Merging Worksheets 

Sometimes, multiple reviewers return edited versions of a worksheet at the same time. In 

this case, it may be quicker to review all of these changes at once, rather than one review 

at a time. For this purpose, Calc provides the feature of merging worksheets. 

To merge worksheets, all of the edited worksheets need to have recorded changes in them. 

1. Open the original worksheet. 

2. Select Edit > Changes > Merge Document. 

3. A file selection dialog opens. Select a file you want to merge and click OK. 

4. After the worksheets merge, the Accept or Reject Changes dialog opens as shown below, 

showing changes by more than one reviewer. If you want to merge more worksheets, 

close the dialog and then repeat steps 2 and 3. 

 
Figure 2.35  Accept or reject for merged worksheets 
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Now all of the changes are combined into one worksheet and you can accept or reject the 

changes. Changes from different authors appear in different colors in the worksheet. In 

this example, all of the changes from Robert are blue and the changes from Mia are red. 

 

Figure 2.36 Merged worksheets with different author colors 

 

Comparing Documents 

When sharing worksheets reviewers may forget to record the changes they make. This is 

not a problem with Calc because Calc can find the changes by comparing worksheets. 

In order to compare worksheets you need to have the original worksheet and the one that 

is edited. To compare them: 

1. Open the edited worksheet that you want to compare with the original worksheet. 

2. Select Edit > Compare Document. 

3. An open worksheet dialog appears. Select the original worksheet and click Insert. 

Calc finds and marks the changes as follows: 

● All data that occurs in the edited worksheet but not in the original is identified as 

inserted. 

● All data that is in your original worksheet but is not in the edited worksheet is 

identified as deleted. 

● All data that is changed, is marked as changed. 

 

QUESTIONS: 

1. What is the purpose of adding comments? 

2. How can we add comments to the changes made? 

3. State True/ False 
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a. Original author of the Worksheet can accept or reject changes made by other users. 

4. Fill up the blanks 

a. Spreadsheet software allows the user to share the workbook and place it in the 

____________ location where several users can access. 

c. Spreadsheet software can find the changes by __________ Sheets. 

 

 

SESSION 4: CREATE AND USE MACROS IN SPREADSHEET  
 

Relevant IKnowledge 

A macro is a saved sequence of commands or keystrokes that are stored for later use. An 

example of a simple macro is one that “types” your address. The OpenOffice.org (OOo) 

macro language is very flexible, allowing automation of both simple and complex tasks. 

Macros are especially useful to repeat a task the same way over and over again.  

Using the macro recorder 

This session provides a basis for understanding the general macro capabilities in 

OpenOffice.org using the macro recorder. The following steps create a macro that 

performs paste special with multiply. 

1. Open a new spreadsheet. 

2. Enter numbers into a sheet. 

 

Figure 2.37   Enter numbers. 

3. Select cell A3, which contains the number 3, and copy the value to the clipboard. 

4. Select the range A1:C3. 

5. Use Tools > Macros > Record Macro to start the macro recorder. The Record Macro 

dialog is displayed with a stop recording button. 



96 

 

 

Figure 2.38   Stop recording button. 

6. Use Edit > Paste Special to open the Paste Special dialog. 

 

Figure 2.39  Paste Special dialog. 

7. Set the operation to Multiply and click OK. The cells are now multiplied by 3. 

 

Figure2.40   Cells multiplied by 3. 

8. Click Stop Recording to stop the macro recorder. The OpenOffice.org Basic Macros 

dialog opens. 

https://wiki.openoffice.org/wiki/File:CG3Ch12F2a.png
https://wiki.openoffice.org/wiki/File:CG3Ch12F3a.png
https://wiki.openoffice.org/wiki/File:CG3Ch12F4a.png
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9. Select the current worksheet. For this example, the current Calc worksheet is Untitled 1. 

Existing worksheets show a library named Standard. This library is not created until the 

worksheet is saved, or the library is needed, so at this point your new worksheet does not 

contain a library. You can create a new library to contain the macro, but this is not 

necessary. 

 

Figure 2.41  Select the Standard library if it exists. 

10. Click New Module. If no libraries exist, then the Standard library is automatically created 

and used. In the New Module dialog, type a name for the new module or leave the name 

as Module1. 

 

Figure 2.42  New Module Dialog Box 

https://wiki.openoffice.org/wiki/File:CG3Ch12F5b.png
https://wiki.openoffice.org/wiki/File:CG3Ch12F0.png
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11. Click OK to create a module named Module1. Select the newly created Module1, enter 

the macro name PasteMultiply and click Save. 

 

Figure 2.43   Select the module and name the macro. 

12. The created macro is saved in Module1 of the Standard library in the Untitled 1 worksheet 

Using A Macro As A Function 

Using the newly created Calc worksheet CalcTestMacros.ods, enter the formula 

=NumberFive() (see Figure 2.44). Calc finds the macro and calls it. 

 

Figure 2.44   Use the NumberFive() Macro as a Calc function  

 Note: Function names are not case sensitive. You can enter =NumberFive() and 

Calc clearly shows =NUMBERFIVE(). 

https://wiki.openoffice.org/wiki/File:CG3Ch12F6a.png
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Save the Calc document, close it, and open it again. Depending on your settings in Tools 

> Options > OpenOffice.org > Security > Macro Security, Calc will display one of the 

warnings shown below. You will need to click Enable Macros, or Calc will not allow any 

macros to be run inside the document. 

 

OOo warns you that a document contains macros. 

 

 

Warning if macros are disabled 

If you choose to disable macros, then when the document loads, Calc can no longer find 

the function. 

 

Figure 2.45 The function is gone. 

 

https://wiki.openoffice.org/wiki/File:CG3Ch12F13a.png
https://wiki.openoffice.org/wiki/File:CG3Ch12F14a.png
https://wiki.openoffice.org/wiki/File:CG3Ch12F14.png
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When a document is created and saved, it automatically contains a library named 

Standard. The Standard library is automatically loaded when the document is opened. No 

other library is automatically loaded. 

Calc does not contain a function named NumberFive(), so it checks all opened and visible 

macro libraries for the function. Libraries in OpenOffice.org Macros, My Macros, and the 

Calc document are checked for an appropriately named function. The NumberFive() 

function is stored in the AuthorsCalcMacros library, which is not automatically loaded 

when the document is opened. 

Use Tools > Macros > Organize Macros > OpenOffice.org Basic to open the 

OpenOffice.org Basic Macros dialog shown further down the page. Expand 

CalcTestMacros and find AuthorsCalcMacros. The icon for a loaded library is a different 

color from the icon for a library that is not loaded. 

Click the expansion symbol (usually a plus or a triangle) next to AuthorsCalcMacros to 

load the library. The icon changes color to indicate that the library is now loaded. 

Click Close to close the dialog. 

Unfortunately, the cells containing =NumberFive() are in error. Calc does not recalculate 

cells in error unless you edit them or somehow change them. The usual solution is to store 

macros used as functions in the Standard library. If the macro is large or if there are many 

macros, a stub with the desired name is stored in the Standard library. The stub macro 

loads the library containing the implementation and then calls the implementation. 

1. Use Tools > Macros > Organize Macros > OpenOffice.org Basic to open the 

OpenOffice.org Basic Macros dialog. Select the NumberFive macro and click Edit to 

open the macro for editing. 

 
Figure 2.46 Select a macro and click Edit. 

https://wiki.openoffice.org/wiki/File:CG3Ch12F16a.png
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2. Change the name of NumberFive to NumberFive_Implementation (see Listing 3). 

Listing 3. Change the name of NumberFive to NumberFive_Implementation 

 

 Function NumberFive_Implementation() 

   NumberFive_Implementation() = 5 

 End Function 

3. In the Basic IDE, hover the mouse cursor over the toolbar buttons to display the tool tips. 

Click the Select Macro button to open the OpenOffice.org Basic Macros dialog. 

4. Select the Standard library in the CalcTestMacros document and click New to create a 

new module. Enter a meaningful name such as CalcFunctions and click OK. OOo 

automatically creates a macro named Main and opens the module for editing. 

5. Create a macro in the Standard library that calls the implementation function (see Listing 

4). The new macro loads the AuthorsCalcMacros library if it is not already loaded, and 

then calls the implementation function. 

Listing 4. Change the name of NumberFive to NumberFive_Implementation. 

 

 Function NumberFive() 

   If NOT BasicLibraries.isLibraryLoaded("AuthorsCalcMacros") Then 

     BasicLibraries.LoadLibrary("AuthorsCalcMacros") 

   End If 

   NumberFive = NumberFive_Implementation() 

 End Function 

Save, close, and reopen the Calc document. This time, the NumberFive() function works. 

 

Passing Arguments to Macros 

To illustrate a function that accepts arguments, we will write a macro that calculates the 

sum of its arguments that are positive—it will ignore arguments that are less than zero 

(see Listing 5). 

Listing 5. PositiveSum calculates the sum of the positive arguments. 

https://wiki.openoffice.org/w/images/b/b2/CG3Ch12F11a.png


102 

 

 

The macro in Listing 5 demonstrates a couple of important techniques. 

1. The argument x is optional. If the argument is not optional and it is called without an 

argument, OOo prints a warning message every time the macro is called. If Calc calls the 

function many times, then the error is displayed many times. 

2. IsMissing checks that an argument was passed before the argument is used. 

3. IsArray checks to see if the argument is a single value, or an array. For example, 

=PositiveSum(7) or =PositiveSum(A4). In the first case, the number 7 is passed as an 

argument, and in the second case, the value of cell A4 is passed to the function. 

4. If a range is passed to the function, it is passed as a two-dimensional array of values; for 

example, =PositiveSum(A2:B5). LBound and UBound are used to determine the array 

bounds that are used. Although the lower bound is one, it is considered safer to use 

LBound in case it changes in the future. 

Note: The macro in Listing 5 is careful and checks to see if the argument is an array or a 

single argument. The macro does not verify that each value is numeric. You may 

be as careful as you desire. The more things you check, the more robust the macro 

is, and the slower it runs. 
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Passing one argument is as easy as passing two: add another argument to the function 

definition (see Listing 6). When calling a function with two arguments, separate the 

arguments with a semicolon; for example, =TestMax(3; -4). 

 

Listing 6. TestMax accepts two arguments and returns the larger of the two. 

 

 

Passing Arguments as Values 

Arguments passed to a macro from Calc are always values. It is not possible to know what 

cells, if any, are used. For example, =PositiveSum(A3) passes the value of cell A3, and 

PositiveSum has no way of knowing that cell A3 was used. If you must know which cells 

are referenced rather than the values in the cells, pass the range as a string, parse the 

string, and obtain the values in the referenced cells. 

  

Writing Macros that act like built-in Functions 

Although Calc finds and calls macros as normal functions, they do not really behave as 

built-in functions. For example, macros do not appear in the function lists. It is possible 

to write functions that behave as regular functions by writing an Add-In.  

 

Accessing Cells Directly  

You can access the OOo internal objects directly to manipulate a Calc document. For 

example, the macro in Listing 7 adds the values in cell A2 from every sheet in the current 

document. ThisComponent is set by StarBasic when the macro starts to reference the 

current document. A Calc document contains sheets: ThisComponent.getSheets(). Use 

getCellByPosition(col, row) to return a cell at a specific row and column. 
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Listing 7. Add cell A2 in every sheet. 

 

 

Sorting 

Sorting data can be automated in Open Office by creating a Macro in Calc. Data can be 

sorted on a single column or more than one column. Each time the Macro runs the data 

gets sorted. Such macros can be written using code in Open Office. 

Consider sorting the data in the figure below. First, sort on column B descending and then 

column A ascending. 

 

.  

Figure 2.47 Sort column B descending and column A ascending. 

The example in Listing 9, however, demonstrates how to sort on two columns. 

 

https://wiki.openoffice.org/wiki/File:CG3Ch12F18.png
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Listing 9. Sort cells A1:C5 on Sheet 1. 

Sub SortRange 

  Dim oSheet        ' Calc sheet containing data to sort. 

  Dim oCellRange    ' Data range to sort. 

  

  REM An array of sort fields determines the columns that are 

  REM sorted. This is an array with two elements, 0 and 1. 

  REM To sort on only one column, use: 

  REM Dim oSortFields(0) As New com.sun.star.util.SortField 

  Dim oSortFields(1) As New com.sun.star.util.SortField 

  

  REM The sort descriptor is an array of properties. 

  REM The primary property contains the sort fields. 

  Dim oSortDesc(0) As New com.sun.star.beans.PropertyValue 

  

  REM Get the sheet named "Sheet1" 

  oSheet = ThisComponent.Sheets.getByName("Sheet1") 

  

  REM Get the cell range to sort 

  oCellRange = oSheet.getCellRangeByName("A1:C5") 

  

  REM Select the range to sort. 

  REM The only purpose would be to emphasize the sorted data. 

  'ThisComponent.getCurrentController.select(oCellRange) 

  

  REM The columns are numbered starting with 0, so 

  REM column A is 0, column B is 1, etc. 

  REM Sort column B (column 1) descending. 

  oSortFields(0).Field = 1 

  oSortFields(0).SortAscending = FALSE 

  

  REM If column B has two cells with the same value, 

  REM then use column A ascending to decide the order. 

  oSortFields(1).Field = 0 

  oSortFields(1).SortAscending = True 
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  REM Setup the sort descriptor. 

  oSortDesc(0).Name = "SortFields" 

  oSortDesc(0).Value = oSortFields() 

  

  REM Sort the range. 

  oCellRange.Sort(oSortDesc()) 

End Sub  

 

 

 

. 

Questions: 

1. What are Macros? 

2. How can we record a Macro? 

3. Fill up the blank 

a. Macros are useful to ___________ a task the same way over and over again. 

  



107 

 

 

 

UNIT-3 RELATIONAL DATABASE MANAGEMENT SYSTEMS (BASIC) 

 

 

SESSION 1: APPRECIATE THE CONCEPT OF DATABASE MANAGEMENT  

                     SYSTEM 

 

SESSION 2: CREATE AND EDIT TABLES USING WIZARD AND SQL  

                     COMMANDS 

 

SESSION 3: PERFORM OPERATIONS ON TABLE 

 

SESSION 4: RETRIEVE DATA USING QUERY 

 

SESSION 5: CREATE FORMS AND REPORTS USING WIZARD 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



108 

 

SESSION 1: APPRECIATE CONCEPT OF DATABASE 

MANAGEMENT SYSTEM 

 

Relevant Knowledge 

A database is an organized collection of data. You can visualize it as a container of 

information. 

The data is typically organized to model relevant aspects of reality (for example, the 

availability of rooms in hotels), in a way that supports processes requiring this information 

(for example, finding a hotel with facilities such as Laundry, GYM etc…). 

 

Suppose if you own a stationary shop, you need to keep detailed records of the materials 

available in your shop. You also need to store information about pricing, stock levels for 

reordering, old stocks, etc. While in the manual system, you would maintain several files 

with different bits of information; in the computerized system you would use database 

programs such as Microsoft Access, OpenOffice.org Base, and MySQL, to organize the 

data as per your business need. 

The database concept has evolved since the 1960s to ease increasing difficulties in 

designing, building, and maintaining complex information systems (typically with many 

concurrent end-users, and with a large amount of diverse data).  

In this lesson, you will learn database concepts and to work with a Database Management 

System (DBMS). 

 

Database Management System 
 

A database management system is a software package with computer programs that 

controls the creation, maintenance, and use of a database. It allows organizations to 

conveniently develop databases for various applications. A database is an integrated 

collection of data records, files, and other objects. A DBMS allows different user 

application programs to concurrently access the same database. 

Well known DBMSs include Oracle, IBM DB2, Microsoft SQL Server, Microsoft 

Access, PostgreSQL, MySQL, FoxPro, and SQLite. 

 

Data can be organized into two types: 

• Flat File: Data is stored in a single table. Usually suitable for less amount of data. 

• Relational:  Data is stored in multiple tables and the tables are linked using a common 

field. Relational is suitable for medium to large amount of data. 
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Database Servers 

Database servers are dedicated computers that hold the actual databases and run only the 

DBMS and related software. Typically databases available on the database servers are 

accessed through command line or graphic user interface tools referred to as Frontends; 

database servers are referred to as Back-ends. Such type of data access is referred to as a 

client-server model. 
 

Advantages of Database 
 

 Reduces Data Redundancy 

The database management systems contain multiple files that are to be stored in many 

different locations in a system or even across multiple systems. Because of this, there 

were sometimes multiple copies of the same file which lead to data redundancy.  

This is prevented in a database as there is a single database and any change in it is reflected 

immediately. Because of this, there is no chance of encountering duplicate data. 

 Sharing of Data 

In a database, the users of the database can share the data among themselves. There are 

various levels of authorisation to access the data, and consequently the data can only be 

shared based with the authorized users. 

Many remote users can also access the database simultaneously and share the data 

between themselves. 

 Data Integrity 

Data integrity means that the data is accurate and consistent in the database. Data Integrity 

is very important as there are multiple databases in a DBMS. All of these databases 

contain data that is visible to multiple users. So it is necessary to ensure that the data is 

correct and consistent in all the databases and for all the users.  

 Data Security 

Data Security is an important concept in a database. Only authorised users should be 

allowed to access the database and their identity should be authenticated using a username 

and password. Unauthorised users should not be allowed to access the database under any 

circumstances as it violates the integrity constraints. 
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 Privacy 
 

The privacy rule in a database states that only the authorized users can access a database 

according to its privacy constraints. To secure data levels are set in the database and a 

user can only view the data which is allowed to be seen. For example - In social 

networking sites, access constraints are different for different accounts a user may want 

to access. 

 Backup and Recovery 

Database Management System automatically takes care of backup and recovery. The 

users don't need to backup data periodically because this is taken care of by the DBMS. 

Moreover, it also restores the database after a crash or system failure to its previous 

condition.  

 Data Consistency 

Data consistency is ensured in a database because there is no data redundancy. Data 

Consistency means there should be multiple mismatching copies of the same data. All 

data appears consistently across the database and must be same for all the users viewing 

the database. Moreover, any changes made to the database are immediately reflected to 

all the users and there is no data inconsistency. 

 

Features of Database 

 

Let’s look at the example of your address book. What do you store in an address book? 

You may have people’s name, address, phone number and maybe even their birthdays. 

There is a common element here – people. In this example, each person is considered an 

“ITEM”.  

So, database will store information about that person. When you were recording 

information in your address book, what did you ask the people? What is your address? 

What is your phone number? etc. Each question that we ask about our ITEM is a “field”. 

Now, say you make new friends and want to add their information to your address book. 

You will ask questions, get the answers and create a new “record”. So, a record is a set 

of information (made up of fields) stored in your database about one of the items. A 

“value” is the actual text or numerical amount or date that you put in while adding 
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information to your database. When you put all the information together in a grid (like 

you do in a spreadsheet), a collection of similar records creates a table. 

There are some key features of a database: 

1. A database can have one or many tables. An address book example is a very simple 

one, in real world there are many more details involved. A big company would have 

in its database, one table for its products, one table for its suppliers, one table for its 

customer details, one for orders received and maybe many others.  

2. Each table in a database contains information about one type of item. So, a database 

is a container that holds tables and other objects and manages how they can be used. 

3. Another very important thing to remember is that when we put in information, we may 

have people with the same name (there can be more than one Charu Arora) or the same 

address (members of a family). But when creating a database an important feature is 

record uniqueness in every table. it is important to be able to distinguish between 

different items having duplicate values. 

Uniqueness helps to avoid accidental duplication of records caused by user or 

computer error. This can be achieved by using some number or value that uniquely 

identifies a record. If such a unique value does not exist in your fields, as the database 

designer, you can create a special additional field in a table where unique numbers or 

values can be assigned for each new entry. Therefore, every table has a key field which 

ensures that there are 100% unique values throughout the database. 

4. Every database table should have one or more fields designated as key.   You can 

assign a unique value to this key for differentiating records that may have similar 

names or addresses. 

 

Look at the following example of student database: 
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In this table, it will be extremely difficult to differentiate between student records as they 

have names that are similar. To differentiate, you can add additional field - roll number - 

that will be unique for each record (example below). 

 

 
 

 

EXAMPLE OF RDBMS 

 

You had used the example of an address book in the previous section. An address book 

uses only one table. But look at a different situation. If you are a dealer selling a single 

type of item and want to record details of your sales in the past month and also want the 

details of the client who purchased the item ( name, address, phone, date purchased, 

number of items bought etc), what would you do?.  

You create a table Sales with all the details: 

 

 
Do you see a problem here? Every time you sell an item to Sheela or Vaibhav or any other 

customer (client) you need to store the details again. So, what is the solution? Create one 

table for client details and another for sale details. Since each record has to be unique, 

you can insert a ClientID field to uniquely identify each client in the client table. In the 

Sales table, you would give a point of reference which “points” to a particular record in 

the Client table. 
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In the example here, the field ClientID occurs once in the Client table, but since one client 

can place many orders, it occurs a number of times in the Sales table. Since we cannot 

have an order without a customer, we call Client the parent and Sales the child table. 

Related tables like these share a common field. You store data about people once, but 

refer to those people many times in the database. 

When data is to be stored, maintained, and retrieved from multiple tables then special 

database software are required known as Relational Database Management System. 

In the RDBMS data can be integrated using keys. These are Primary Key, Composite 

Primary Key, and Foreign Key. 

This unique field is called the Primary Key (PK). A primary key is a unique value that 

identifies a row in a table. In our example, ClientID is the primary key in the Client table. 

Primary Keys are also indexed in the database, making it faster for the database to search 

for a record. When primary key constraint is applied on one or more columns then it is 

known as Composite Primary Key. 

The referred field ClientID which occurs in the Sales table is called the Foreign key (FK). 

Hence, the foreign key identifies a column or set of columns in one (referencing) table 

that refers to a column or set of columns in another (referenced) table. The “one” side of 

a relation is always the parent, and provides the PK attributes to be copied. The “many” 

side of a relation is always the child, into which the FK attributes are copied. Memorize 

it: one, parent, PK; many, child, FK. 
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Another point to remember is that the end users will/may never have direct access to the 

database. They can only see what you permit them to and can select only from the options 

you give them. 

 

RDBMS 

A relational database is a type of database. It uses a structure that allows us to identify 

and access data in relation to another piece of data in the database. Often, data in a 

relational database is organized into tables. 

 

ACTIVITIES 

 

1. Analyze database requirements for a retail shop. Record the business requirements and 

document. (You can use this information for creating a database to suit this business 

requirement) 

2. Analyze database requirement for your school; visit different departments such as library, 

student admission center, to gather requirements. Document the business requirement. 

(You can use this information for creating a database to suit this requirement 

 

ASSESSMENT 

 

Fill in the blanks: 

 

1. A __________ is an organized collection of data. 

2. A ________________ is a software package that can be used for creating and managing 

databases. 

3. A ____________ is a database management system that is based on the relational 

model. 

4.Three popular DBMS software are ________, ________, & _______. 

5. A ____________ is a unique value that identifies a row in a 

table. 

6. Composite Key is a combination of ________ columns. 

 

Short Answer Questions  

1. What does DBMS stands for?  

2. What does RDBMS stands for?  

3. How is data organized in a RDBMS? 
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4.State the relationship and difference between a primary and foreign key?  

 

 

SESSION2:CREATE AND  EDIT TABLES USING WIZARD & SQL  COMMANDS 

 

Relevant Knowledge 

Data in a relational database management system (RDBMS) is organized in the form of 

tables. 

You will now quickly recap what you learnt in the last session and assimilate more 

concepts. 

 

RDBMS 

A relational database is a collective set of multiple data sets organized by tables, records 

and columns. Relational database establish a well-defined relationship between database 

tables. Tables communicate and share information, which facilitates data searcheability, 

organization and reporting. A Relational database use Structured Query Language (SQL), 

which is a standard user application that provides an easy programming interface for 

database interaction 

 

DATABASE OBJECTS 
 

Tables: 

A table is a set of data elements (values) that is organized using a model of vertical 

columns(which are identified by their name) and horizontal rows. A table has a defined 

number of columns, but can have any number of rows. Each row is identified by the values 

appearing in a particular column identified as a unique key index or the key field. 

 

Columns or Fields or Attributes: 

A column is a set of data values of a particular simple type, one for each row of the table. 

The columns provide the structure according to which the rows are composed. For 

example, cFirstName, or cLastName are fields in a row. 

 

Rows or Records or Tuples: 

A row also called a Record or Tuple represents a single, data item in a table. In simple 

terms, a database table can be visualized as consisting of rows and columns or fields. Each 
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row in a table represents a set of related data, and every row in the table has the same 

structure. 

 

 

CREATING DATABASE USING OPENOFFICE 

 

There are a variety of DBMS/RDBMS available; in this exercise, you will learn about 

OpenOffice Base an Open Source RDBMS. 

 

• To open OpenOffice, click Start>Programs>OpenOffice.org 4 >    

  OpenOffice.org. 

  Alternatively, you can also double-click on the OpenOffice.org 4 shortcut   on the 

desktop if available. You should see a Window similar to the one  displayed below 

                
FIGURE 1 

 

Select the option database to open the base application. 

You can also directly open the OpenOffice Base Application by doing the following: 

• Click Start>Programs>OpenOffice.org 4>OpenOffice.org Base.  

  You should be guided through the Database Wizard for creating a database.      

  You will see a dialog box similar to the one displayed below. 
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FIGURE 2 

You can create a new database by selecting the option Create a new database. 

You can also open an existing database file that you have already created by selecting the 

option Open an existing database file. Click Next.  

 

A dialog box similar to the one displayed below appears. 

               
Figure 3 
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Click Finish. The Save As dialog box appears as shown below. 
 

Specify a name for the database in the File name: field and click Save. A window similar 

to the one displayed below. 
 

Click Finish. The Save As dialog box appears as shown below. 

 
                                                  Figure 4 

Specify a name for the database in the File name: field and click Save. A window similar 

to the one displayed below. 

 
Figure 5 
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Now that you have created a database, you can work with the database as outlined in the 

next few sessions. 

 

Steps To Create A Table Using Table Wizard 
 

Tables are the basic building blocks of a database. You store the data in the database in 

the form of tables. In the previous exercise you have learnt how to create database objects 

in OpenOffice. 

In this exercise you will learn how to create a table in a database. 

After creating the database, you see a window as shown below. 

There are different ways to create a table: 

1. Create table in Design View 

2. Use Wizard to Create Table 

 

 
                                                   Figure 6 

Use Wizard To Create Table: 

A table can be created using the predefined steps and table structure(s) in Base. 

The following are the steps to create a table: 
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Click on Tables > Use Wizard to Create Table , the window shown below will open 

 
FIGURE 7 

Click the Select Fields > Choose Category  > Select the table (in the picture shown below 

“Business” category and “Customer” table has been chosen) > Click on Next Button. 

 
FIGURE 8 
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Select the fields as per the requirements and select on  buttons to add the predefined 

columns or select  to remove the fields from the Selected Fields Box. After selecting 

the fields click on Next Button.  

 

 
      FIGURE 9 

 

Once the fields will be selected the window to set the data types will open, By default all 

the fields will have Text[VARCHAR] data type which can be and other properties with 

default values but all of them can be selected as per the requirement. 

 

Click on Next Button 
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FIGURE 10 

After setting the properties of the fields such as field name, type etc. The window to set 

the primary will open. Base automatically adds the column to be set as Primary Key which 

will help the user to enter the unique values and helps in creating the relationship with the 

other table to extract the data from multiple tables. 

After setting the Primary Key click on Next Button.  

 
 

FIGURE 11 
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When the Primary Key will be set then window to rename the table will open. A user can 

either go ahead with the same table name or can change it.  
 

In the same window options to work with the table will be given as : 

                                
The option to insert the data immediately will be selected by default . Click on Finish to 

insert the data in the table.   

           
               FIGURE 12 

To insert the data the following window open: 

             
                 FIGURE 13 
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Creating table using Design View 

 

1. Click on Create Table in Design View… option available under Tasks and a Table Design 

window appears as shown below. 

                                
                                                    Figure 14 
 

Specify the field name and data type of the field to be created by selecting the appropriate 

type available under Field type dropdown list. 

Now create a table with the following fields displayed below: 

Specify the field name and the data type for each field name. For example, the table 

contains the Name field and the data type of the Name is TEXT [VARCHAR]. You can 

specify the length of the field value. 
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Figure 15 

 

Specify the table name. The default name is Table1. Click OK. 

 
Figure 16 

A dialog box appears, similar to the one displayed below. 

                             
Figure 17 
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Options to set Primary Key 

 

You are asked to set a primary key for the table you just created. You can select the 

appropriate option to set the primary key or leave the table without a primary key. 

If you click Yes, the application will set the primary key for the first field created 

automatically. If you click No, you should see a window similar to the one displayed 

below. 

 
Figure 18 

Notice the table by the name SDetails created and visible under Tables section. 

 

Data Types: 

Datatypes are used to identify which type of data (value) we are going to store in the 

database. 

Fields themselves can be of different types depending on the data they contain. Data types 

in OpenOffice base are broadly classified into five categories listed below. 

• Numeric Types 

• Alphanumeric Types 

• Binary Types 

• Date time 

• Other Variable types 

 

Numeric Types: 

Numeric data types are used for describing numeric values for the field used in the table 

of a database. Numeric data types in a database can be used for storing information such 
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as mobile number, roll number, door number, year of school admission, true or false 

statements, statistical values, etc.                

The different types of numeric data types available are listed here. 

 
 

Alphanumeric Types: 

 
 

Binary Types: 

Binary data types are used for storing data in binary formats. Binary data types in a 

database can be using for storing photos, music files, etc. In general, files of any format 
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can be stored using the binary data type. The different types of binary data types available 

are listed here. 

 
DATE TIME: 

Date time data types are used for describing date and time values for the field used in the 

table of a database. Date time data types in a database can be used for storing information 

such as date of birth, date of admission, date of product sale, etc.  

 

The different types of date time data types available are listed here. 

 

Other Data Types: 

 
 

Create the following records: 
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Table Data View Dialog Box 
 

                  
                                       Figure 19 

Start typing the records in the table with the data provided in the excel sheet and select 

File > Save Current ecord to save data in the table. 

 

ACTIVITIES 

1.   Create a database for a stationery shop.  

Hint: Create fields for items, price, colour, vendor, etc.  

2.  Create a database for a school library. 

Hint : Create fields for book title, cost, provider, availability, etc 

3. Create a database for maintaining a song collection. 

Hint : Create fields for fields such as artist, movie, year released, etc. 

 

ASSESSMENT 

Fill in the blanks:  

1. A table is a set of data elements that is organized using a model of vertical ___________ 

and horizontal ____________. 

2. A _________ is a set of data values of a particular type, one for each row of the table. 

3. A ___________ represents a single, data item in a table. 

4.  _____________ are used to identify which type of data we are going to store in the 

database. 

5.  There are ________ ways to create a table. 

6. Field properties can be set in both the ________ and _________ . 

 

Short Answer Questions 
 

1. In how many ways tables can be created in Base?   

2. Why are data types used in DBMS /RDBMS?  

3.  List datatypes available in Numeric Datatype?  
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4.  List datatypes available in Alphanumeric Datatype?  

5.  Define the structure of a table. 

6.  Differentiate between Tuples and Attributes of a table. 

7.  Name different Binary data types. 

 

 

SESSION 3: PERFORM OPERATIONS ON TABLE 

 

Relevant Knowledge 
 

In Base, data is stored in tables which can be inserted, modified and removed using 

appropriate options.  

You will now quickly recap what you learnt in the last session and assimilate more 

concepts. 

 

Inserting Data In The Table 

 

To insert the data in the table, follow the steps: 

Select the table > Double click on it.  

 
     FIGURE  20 

The table will open in Datasheet View in which data new data can be inserted and existing 

data can be updated or removed. 
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FIGURE 21 

 

Editing Records In The Table 

To edit the data either click on edit icon  or double on the data in the cell of a table 

and modifications can be done. 

 
     FIGURE  22 
 

Deleting Records From The Table 

 

To remove the data from the table, follow the steps: 

Select the data > right click on selected data > select the Delete option 
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                            FIGURE 23 

Field Properties 

 

To change the field properties table structure in design view has to be changed. To 

set the field properties, steps will be followed as: 

Select the table > Right click > Select the option Edit > the table Design View window 

will open 

          
FIGURE 24 
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In design view there are different properties of fields according to the data type set for 

each field.  
 

The properties of numeric type data is shown below in the figure. 

Like AutoValue – if set to yes then field will get the auto numeric values. 

Length – By default length of the field is 10 but the size of the field can be set to 

maximum length. 

Default Value – A default value can be set for a field if user don’t provide any  value 

while entering the values in the table.  

Format example – This property helps to set the format of the data entered in the field 

such as 91-222-333.  

 
Figure 25 

The properties of character type data is shown below in the figure. 

Entry Required – if set to yes then it will be must to insert the value in the field which 

means that field cannot be left blank. 

Length – By default length of the field is 10 but the size of the field can be set to 

maximum length. 
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Default Value – A default value can be set for a field if user don’t provide any value 

while entering the values in the table.  

Format example – This property helps to set the format of the data entered in the field 

such as 91-222-333. 

 
      FIGURE 26 

Sorting Data 

Sorting means to arrange the data in either ascending order of descending order. Select 

the column(s) then click on sort buttons. The data will be displayed accordingly. 

 

Unsorted Column (EMP_NAME)                     Sorted Column (EMP_NAME) 

          
               Figure 27                                                     Figure 28 
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Referential Integrity 

Referential integrity is used to maintain accuracy and consistency of data in 

a relationship. 

In Base, data can be linked between two or more tables with the help of primary key and 

foreign key constraints. 

Referential integrity helps to avoid: 

 Adding records to a related table if there is no associated record available in the 

primary key table. 

 Changing values in a primary if any dependent records are present in associated 

table(s). 

 Deleting records from a primary key table if there are any matching related records 

available in associated table(s). 
 

Creating and Editing Relationships between Tables  

A relationship refers to an association or connection  between two or more tables. When 

you relate two tables, you don't need to enter the same data in separate tables.  

Relationships between tables helps to: 

 Save time as there is no need to enter the same data in separate tables. 

 Reduce data-entry errors. 

 Summarize data from related tables. 

You can create a relationship between any two tables by selecting Relationships… option 

from the Tools menu. 

 
Figure 29 

https://database.guide/what-is-a-relationship/
https://database.guide/what-is-a-table/
https://help.quickbase.com/user-assistance/what_is_a_table.html
https://help.quickbase.com/user-assistance/creating_a_relationship.html
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Add the tables in amongst which you want to create the relationship. Select the tables and 

click on Add button. 

 
Figure 30 

There are three types of relationships which can be created in tables: 

1. ONE to ONE 

2. ONE to MANY  OR MANY to ONE 

3. MANY to MANY 

There are two ways to create the relationships between the tables: 

a. Click on Insert option and select New Relation… option in Relation  

      Design window.  

 
Figure 31 
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Select the options as required: 

 
Figure 32 

b. Drag the primary key column from one table and drop it on the key column of another 

table. 

 

One to One Relationship 

In this relationship, both the tables must have primary key columns. Example: In the given 

tables EMP and DEPT, EMP_ID in EMP table and DEPT_ID in DEPT table are the 

primary keys. 

                        
                                                  Figure 33 
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One to Many Relationship 

In this relationship, one of the table must have primary key column. 

It signifies that one column of primary key table is associated with all the columns of 

associated table.  

Example: In the given tables EMP and DEPT, EMP_ID in EMP table is the primary key. 

 
Figure 34 

 

Many to Many Relationship 

In this relationship, no table has the primary key column. 

It signifies that all the columns of primary key table are associated with all the columns 

of associated table.  

Example: In the given tables EMP and DEPT, there is no primary key. 

 

                          
Figure 35 
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Remove the Relationships 

The relationships applied on the tables can be removed also with the help of Delete option. 

Right Click on the relationship thread and select Delete option. 

                             
                                                    Figure 36 

 

ACTIVITIES 

 

Perform the following activities till you are confident: 

1. Create a database to store your academic records using the guidelines below:  

• Use your roll number as the file name for your database.  

• Create fields such as subject name, required score, passing score and your

 percentage.  

• Set the subject name field as the primary key. Populate your database with your 

most recent exam results0 

 

ASSESSMENT  

 

Fill in the blanks:  

1. The types of languages used for creating and manipulating the data in the Database are 

______________ & ______________.  

2. A ____________________ is a standard for commands that   define the different 

structures in a database.  

3. A ______________ is a language that enables users to access and manipulate data in a 

database.  

4. A _____________ is a part of DML involving information retrieval only.  

5. A popular data manipulation language is _________________.  
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6. __________ are the basic building blocks of a database.  

7. There are __________ types of Relationships in a table. 

 

Short Answer Questions:  

1. What is the file extension for databases created using OpenOffice.Org 

Base?  

2. List any three file formats that can be managed using 

OpenOffice.Org Base? 

3.How many types of relationships can be created in Base? Explain each of the them. 

4.What do you mean by Sorting? In how many ways it can be done? 

5.Explain Referential Integrity with the help of an example.   

 

 

SESSION 4: RETRIEVE DATA USING QUERY  

 

Relevant Knowledge 

Having created the tables and entering data into them, now you want to extract some 

information. 
 

That’s when you query the database. As the name suggests, query is to collect specific 

information from the pool of data. A query helps us join information from different tables 

and filter that information. Filtering means that the query uses criteria you provide to 

hide some data and present only what you want to see. 

 

Query Creation Using Wizard 

 
FIGURE 37 
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FIGURE 38 

Click on Finish 

 
FIGURE39 
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Creation Of Query Using Design View 

 

Some RDBMS provide a graphical means to create queries, but most RDBMS do not do 

so. That’s where you use SQL (pronounced as “sequel”) or Structured Query Language. 

Query languages are computer languages used to make queries into databases and 

information systems. Queries 

are commands that are used to define the data structure and also to manipulate the data in 

the database. 
 

A SELECT statement retrieves zero or more rows from one or more database tables or 

database views. In most applications, SELECT is the most commonly used Data 

Manipulation Language(DML) command. 
 

The SELECT statement has many optional clauses: 

            • WHERE specifies which rows to retrieve. 

            • ORDER BY specifies an order in which to return the rows. 
 

To retrieve all the columns in a table the syntax is:      

SELECT * FROM <TABLENAME>; 

In order to execute queries click on the Queries option available on the left side under 

database section, click Create Query in SQL View as shown below.  

 
Figure 40 

A window appears similar to the one displayed below. 
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Figure 41 

 

You can type the query in the above window and execute it by using the F5 function key 

or by clicking the icon in the window. 

For example, if you want to display all the data in the table that you created in the early 

session, then the select statement will be:  

                                 Select * from SDetails; 

After executing the select query the output will be shown similar to the one displayed 

below. 

 
Figure 42 

Performing calculations 

In Base, simple calculations can be done on the data using arithmetic operators.  

Example:  

To display the salary of all the employees after incrementing by 1000 then the 

following SQL command will be executed in Base SQL Design  
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Select “EmployeeID”, “FirstName”, “Salary” +1000  

from “Employee” 

 
FIGURE 43 

To display the salary of all the employees after decreasing by 10000 then the 

following SQL command will be executed in Base SQL Design  
 

Select “EmployeeID”, “FirstName”, “Salary” - 10000 

            from “Employee” 

 
FIGURE 44 

 



145 

 

To display the salary of all the employees after incrementing it as twice the amount 

of present salary, then the following SQL command will be executed in Base SQL 

Design.  
 

Select “EmployeeID”, “FirstName”, “Salary” * 2 from “Employee” 
 

 
FIGURE 45 

To display half of the salary amount paid to the employees, then the following SQL 

command will be executed in Base SQL Design.  

Select “EmployeeID”, “FirstName”, “Salary”/2 from “Employee” 

 
                                                FIGURE 46 
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Grouping of Data 

To display the records containing the same type of values “WHERE” clause can be used 

with the Select SQL Command.  

To get details about the list of students whose favorite color is blue, you can use: 

                      select * from SDetails where Color=’Blue’; 

After executing the select query the output will be shown similar to the one displayed 

below. 

 
Figure 47 

To view records in ascending order of RollNo, from the table the select statement will be: 

                  select * from SDetails order by “Rollno” ASC; 

 
Figure 48 

You can add, modify or delete records using the Insert, Update and Delete commands. 
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To type and execute SQL commands, click on Tools > SQL. A window similar to the one 

below will be displayed. 

                                      
                                             Figure 49 

You can type the SQL Commands in the Command to execute space and click on 

Execute. 
 

UPDATE statement 

Update statement is used for modifying records in a database. The general syntax of the 

update statement is as follows: 

UPDATE <table_name>  

SET <column_name> = value [, column_name = value ...]                

[WHERE <condition>]; 
 

To update a record using an update statement, type the following and click Execute. 

Update SDetails set Location = ‘Bhubaneswar’ where Rollno = 14; 

Execute select query to view the updated table. After execution you should see a window 

similar to the one displayed below. 

                       
                                            Figure 50 
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Activities 

1. Open the database created in the previous activity. Use the select query statement to query 

and sort on subjects marks scored was greater than 50%. 

2. Create a database for collecting and maintaining census data. Using queries display the 

data of people living in a specific area. 

Hint : Create fields for fields such as First Name, Last Name, DOB, Place of birth, 

Employment Status, etc. 

 

Assessment 

 

Fill in the blanks 

 

1. A _______ helps the user to systematically store information in the database. 

2. A ________ enables users to view, enter, and change data directly in database objects 

such as tables. 

3. _________ statement retrieves zero or more rows from one or more database tables or 

database views. 

4. By default, data is arranged in _______ order using ORDER BY clause. 

5. __________ statement is used for modifying records in a database. 

6. __________ statement is used to remove one or more records in a Database. 

 

Short Answer Questions: 

1. Name DML commands.  

2. What is the purpose of using queries? 

3. Which clause of Select statement helps to display specific data? 

4. Differentiate between Where and Orderby clause of SQL statements. 

5. State the purpose of Update Command with the help of an example.  

 

 

SESSION 5: CREATE FORMS AND REPORTS USING WIZARD 
 

Relevant Knowledge 

A form provides the user a systematic way of storing information into the database. It is 

an interface in a user specified layout that lets users to view, enter, and change data 

directly in database objects such as tables. 
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In this session, you will learn to create a form. 

 

Creating Form Using Wizard 

To create a form, Click on Forms option located under Database section (Figure below). 

 
Figure 51 

Steps To Create Form Using Wizard 

Click Use Wizard to Create Form… option under Tasks group. The Form Wizard dialog 

box appears as shown below. 

 
Figure 52 

You can select selective fields to be sent onto the form by selecting the field name and 

clicking >button. You can select individual fields in a database or all fields in a database. 
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To use all the fields in the table in a form, click the >> button. 

Notice the fields displayed under Fields in the forms section (Figure below). 

 

 
                                                                Figure 53 

Click Next >. You see the Set up a sub form step dialog box of the wizard as shown below. 

 
                                                              Figure 54 

 

You can select the option Add Subform if you need to insert the contents in the table in 

a separate form. Click Next>. 

 

Now you need to arrange selected fields in a form. You can use different styles from the 

list displayed below: 
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                                                  Figure 55 

Once you have selected a style, click Next > 

A dialog box appears wherein you can select the data entry model. 

 
                                                      Figure 56 

Click Next >. You should see a dialog box wherein you can specify the styles to be used 

in the form. 
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                                                      Figure 57 

 

Click Next >. You see a dialog box where you can specify the name of the form. Click 

Finish. 

 
Figure 58 
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A form window appears. Notice that the records in the table are displayed automatically 

within the form that you just created. 

 
Figure 59 

Options To Enter Data From Forms 

You can add new records to the table using the form by clicking the  symbol located 

at the bottom as shown below. 

 
Figure 41 

Once you click the  symbol, you will be displayed with a window for creating 

records (Figure below). 
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                                                      Figure 60 

You have learnt to create records using design view in the earlier sessions. You can add 

records using the form as displayed below. Type the following data in the textbox 

provided in the box as shown below: 
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To view the saved records, Double-click SDetails (Table name) under Tables section. A 

window similar to the one below will be displayed; notice the record that you created 

using a form is also displayed along with other records (Figure below). 

 
Figure 61 

Now enter three more records using the form and view them using the above mentioned 

procedure. 

 

Reports 

A report helps to display the data in a summarized manner. It is used to generate the 

overall work outcome in a clear format. You can create reports in the database. 

 

Concept Of Reports In Base 

The reports can be created using Openoffice Base.  

 

Creating Reports using wizard 

Reports helps to get the summarized data. To create reports in Base, the table must be 

selected from using which data can be displayed in a format as required.   

 

The steps to create followed are : 

 Click on Reports section under Database in the OpenOffice base application. 

 Once you select the option, you should see a window similar to the one displayed 

below. 
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Figure 62 

Now we can generate the report for the table created earlier. 

Click on Use Wizard to Create Report… option available under Tasks. 

Once you select the Use Wizard to Create Report… option.  

You should see a window similar to one displayed below. 

 
Figure 63 

You have to select all the table fields by selecting the >> button, once you click the button 

>> you should see a dialog box similar to the one displayed below. 
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Figure 64 

Once you click Next>.you should see a dialog box similar to the one displayed below. 

                        
Figure  65 

You can redefine the label of the fields in the reports or else you can set the default name. 

Once you click Next >, you should see a dialog box similar to the one displayed below. 
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Figure 66 

You can define grouping for the fields of the table. 

Once you click Next >, you should see a dialog box similar to the one displayed below. 

 
Figure 67 

You can sort the field variables in the report by selecting the appropriate field and sorting 

method. 

Once you click Next >, you should see a dialog box similar to the one displayed below. 
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Figure 68 

You can select the layout of the report by selecting the appropriate option available under 

the Layout of data down list and you can also select the orientation of the report. 

Once you click Next >, you should see a dialog box similar to the one displayed below. 

 

 
Figure 69 
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You can define a name for the report or you can use the name of the table itself for the 

report also. 

Click Finish. 

Once you click Finish you should see a window similar to the one displayed below with 

the report. 

 

 
Figure 70 

Now create a report containing only Name, RollNo and Phone details. Use different 

layouts for the report design. 

 

ACTIVITIES 

 

1. Create a form for the academic database created in the above activity. Populate the 

table with mark results using the form. 

2. Create a report to display data from table stored in database created earlier. A report 

must display your entire academic score card. 
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Fill in the blanks: 

 

1. To create a form you need to select _________ option available under Database section. 

2. A ______ is helps to collect specific information from the pool of  data in the database. 

3. ________ is used to display the display the summary of data. 

4. _________ are the interfaces with which the user interacts. 

5. Data from multiple tables can be stored in _______. 

 

Short Answer Questions: 

 

1.   Why there is a need to create Forms? 

2.   What is the purpose of creating Reports? 

3.   What are the prerequisites to create a Form and Reports? 

4.   Differentiate between Forms and Reports. 

5.   Can a form displays data from queries? 

6.   In how many ways Forms and Reports can be created in a database?  
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UNIT-4    WEB APPLICATIONS AND SECURITY 

  

SESSION 1: WORKING WITH ACCESSIBILITY OPTIONS  

SESSION 2: NETWORKING FUNDAMENTALS   

SESSION 3: INTRODUCTION TO INSTANT MESSAGING  

SESSION 4: CHATTING WITH A CONTACT – GOOGLE TALK  

SESSION 5: CREATING AND PUBLISHING WEB PAGES – BLOG   

SESSION 6: USING OFFLINE BLOG EDITORS  

SESSION 7: ONLINE TRANSACTIONS  

SESSION 8: INTERNET SECURITY   

SESSION 9 : MAINTAIN WORKPLACE SAFETY  

SESSION 10 : PREVENT ACCIDENTS AND EMERGENCIES  

SESSION 11 : PROTECT HEALTH AND SAFETY AT WORK  

    

SESSION 1: WORKING WITH ACCESSIBILITY OPTIONS  

Relevant Knowledge  

Computer Accessibility refers to the user friendliness of a computer system for all, 

regardless of their disability. This is mainly a software issue. However, when a 

combination of hardware and software, it enables a person with a disability or impairment 

to use a computer. It is known as Assistive Technology. In this session, you will learn 

about the basic accessibility options available on your computer.  

There are numerous types of impairment that impact computer usage. These include:  
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• Cognitive impairments and learning disabilities, such as dyslexia, attention deficit 

hyperactivity disorder (ADHD) or autism.  

• Visual impairment such as low-vision, complete or partial blindness, and color 

blindness.  

• Hearing impairment including deafness.  

• Motor or dexterity impairment such as paralysis, cerebral palsy, or carpal tunnel 

syndrome and repetitive strain injury.   

Accessibility Options in Control Panel are used to customize the way your keyboard, 

display, or mouse function. Many of these features are useful for people with disabilities 

as discussed earlier. In this session, you will learn to use accessibility options in Windows 

XP.    

Launching Accessibility Options  

• To launch accessibility options in WindowsXP, Click 

Start > Control Panel > Accessibility Options.   

The Accessibility Options window appears.  

Keyboard Tab  

 

Sticky Keys  

StickyKeys is an accessibility feature to help 

computer users with physical disabilities, but it is 

also used by others as a means to reduce repetitive 

strain.   

StickyKeys allows the user to press and release a modifier key, such as Shift, Ctrl, Alt, or 

the Windows key, and have it remain active until any other key is pressed.  

To enable StickyKeys, select Use StickyKeys.  

• Click Apply.  

• Click OK.  

The Sticky Keys icon appears in the system tray (figure 2).  

 

Figure: 1 
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After having enabled Sticky Keys, you W’II now practice and see its effect.  

• Start Notepad. To do so, click Start > All Programs > Accessories > Notepad.  

• Type some text (3 - 4 lines at least) and place the cursor at the beginning of the 

text.  

• Press CTRL key on your keyboard.  

• Press letter A on your keyboard.  

Notice the entire text gets selected. This action is equivalent to pressing CTRL+A 

simultaneously!  

To disable Sticky Keys,  uncheck Use Sticky Keys and then click on Apply > OK.  

 Filter Keys  

Filter Keys is a feature of Microsoft Windows. It is an accessibility function that tells the 

keyboard to ignore brief or repeated keystrokes, making typing easier for people with 

hand tremors.  

• To enable Filter Keys, check Use Filter Keys.  

• Click Settings under Filter Keys and check “Ignore Repeated Keystrokes”.  

• Click Apply.  

• Click OK.  

The FilterKeys icon appears in the system tray (figure 3).  

 
After having enabled FilterKeys, you will now practice and see its effect.  

• Start Notepad and type some repeated characters.  

Notice that the repeated characters are ignored  

To disable FilterKeys, uncheck Use FilterKeys and then click on Apply > OK.  

ToggleKeys  

ToggleKeys is also a feature of Microsoft Windows. It is an accessibility function which 

is designed for people who have vision impairment or cognitive disabilities. When 
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ToggleKeys is turned on, computer emits sound cues when the locking keys (Caps Lock, 

Num Lock, or Scroll Lock) are pressed. A high sound is emitted when the keys are 

switched on and a low sound is emitted when they are switched off.  

• To enable ToggleKeys, Check Use ToggleKeys.  

• Click Settings under ToggleKeys. •   Click Apply  

• Click OK.  

Having enabled ToggleKeys, you can see its effect by any one of the following keys NUM 

LOCK, CAPS LOCK or SCROLL LOCK. Notice that on doing so, you hear a beep.   

To disable ToggleKeys, uncheck Use ToggleKeys and then click on Apply > OK.  

Sound Tab  

Select the Sound Tab. A window with options to configure 

accessibility options for sound is displayed (figure 4).  

 

 

SoundSentry  

SoundSentry is designed to help users with auditory impairments. SoundSentry generates 

visual warnings, such as a blinking title bar or a flashing border, whenever the computer 

generates a sound.  

• To enable SoundSentry, Check Use SoundSentry under Sound Tab. Doing so 

activates a drop down list wherefrom you can choose the type of visual warning 

desired.  

• Click Apply.  

• Click OK.  

For understanding SoundSentry, you need to create an error!  

• Click Start> Run. Type note instead of notepad and press Enter.  

• Type some repeated characters in the notepad. Notice that the desktop will flash for a 

fraction of second along with visual error sound code.  

To disable SoundSentry, uncheck Use SoundSentry and then click on Apply > OK. 
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ShowSounds  

ShowSounds instructs applications that convey information by sound, to also provide 

information visually, through text captions or informative icons.  

• To enable ShowSounds, Check Use ShowSounds under Sound Tab.  

• Click Apply.  

• Click OK  

 

Display Tab  

Select the Display Tab. A window with options to 

configure accessibility options for display is displayed.  

High Contrast  

High Contrast is an accessibility feature to assist people 

with vision impairment. You can change the size and color 

of fonts and the background for ease of viewing.  

• To enable HighContrast, Check Use HighContrast   

• Under Display Tab (figure 5).  

• Click Apply.  

• Click OK.  

Notice the difference on your monitor as the High Contrast option is enabled.  

To disable High Contrast, uncheck Use High Contrast > Apply > OK.  

Cursor Options  

Cursor Options is also an accessibility feature that assists people with vision impairment 

by changing the blink rate and width of the cursor.  

• To change the speed of the cursor blink, move the Blink Rate slider back and forth. 

Notice the cursor blinking at various speeds.  
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• To change the width of the cursor, move the Width slider back and forth. Notice the 

with of the cursor changing.  

 

Mouse Tab  

MouseKeys  

MouseKeys is an accessibility feature that assists people who have difficulty using a 

mouse. This option uses the keyboard (especially numeric keypad) as a pointing device 

instead of a mouse. Select the Mouse Tab, a window to configure accessibility options 

for mouse will be displayed(Figure 6).  

• To enable MouseKeys, Check Use MouseKeys.  

• Click Apply.  

• Click OK.  

 
Notice the MouseKey icon in the System Tray (figure 7).  

 

Use number pad keys for moving mouse pointer instead of using mouse after enabling 

“Use MouseKeys”. Use number key 4 to move left, 6 to move right, 2 to move down and 

8 to move up. To disable MouseKeys, uncheck Use MouseKeys and then click on Apply 

> OK.  

 

General Tab  

This tab enables you to configure accessibility options for all users.  

Select the General Tab, a window to configure additional accessibility options will be 

displayed (figure 8).   

 “Turn off accessibility features after idle for”,   

“Give warning message when turning a feature on” and   



168 

 

“Make a sound when turning a feature on or off”.   

Now check these features one by one and see what happens. 

 

    

Serial Keys  

Serial Keys is an accessibility feature that assists 

people that have difficulty using a keyboard or a 

mouse (or both). They can use special devices 

such as Sip, Puff and Breath Switches to provide 

input to the computer through Serial Ports.  

For example, sipping on the tube activates one 

device, while puffing on the same tube activates 

another.  

• Apply all settings to logon desktop can be used to apply configured accessibility 

options to this user at logon.  

• Apply all settings to defaults for new users can be used to apply configured 

accessibility options to all users using a particular computer.  

Perform the following activities on computer 

1. Use StickyKeys option 

2. Use SoundSentry option 
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3. Use High Contrast option 

4. Use SerialKeys option 

 

Assessment  

Fill in the blanks 

1. The option in Microsoft Windows XP used for helping users with physical disabilities 

and to reduce repetitive strain is ____________________. 

2. Sound Sentry is designed to help users with ______________________ impairments. 

3. The High Contrast option in Microsoft Windows XP is designed to assist people with 

________________ impairments. 

4. ___________________ is designed to assist people that have difficulty using a 

keyboard or a mouse. 

 

 

SESSION 2 : NETWORKING FUNDAMENTALS  

Relevant Knowledge  

A computer network is a collection of computers and other hardware components 

interconnected by communication channels (cables or satellites) that allow sharing of 

resources and information.  

This session introduces you to the basic fundamental concepts of networking and Internet 

and using different types of Internet connection.  

Networks are designed using the following architecture:  

PEER-TO-PEER (P2P) ARCHITECTURE:  

Networks in which all computers have an equal status are called peer to peer networks. 

Generally in such a network each terminal has an equally competent CPU.  

CLIENT-SERVER ARCHITECTURE:  

Networks in which certain computers have special dedicated tasks, providing services to 

other computers (in the network) are called client server networks. The computer(s) which 

provide services are called servers and the ones that use these services are called clients.  
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TYPES OF NETWORKS  

There are two major types of network Local Area Network (LAN) and Wide Area 

Network (WAN).  

 LOCAL AREA NETWORK  

A local area network (LAN) is one which connects computers and devices in a limited 

geographical area such as home, school, computer laboratory, office building, or closely 

positioned group of buildings.  

Usually local area networks offer very high speeds and are used for connecting computers 

and peripherals such as printers, scanners, etc.  

 WIDE AREA NETWORK  

A wide area network (WAN) is one which covers a broad area (i.e., any network that links 

across metropolitan, regional, or national boundaries). The Internet is the most popular 

WAN, and is used by businesses, governments, non-profit organizations, individual 

consumers, artists, entertainers, and many others.  
 

INTERNET  

The Internet is a global system of interconnected computer networks that use the standard 

Internet protocol suite to serve billions of users worldwide. It is a network of networks 

that consists of millions of private, public, academic, business, and government networks.  

Internet is one of the most useful technologies of modern times which help us in our daily, 

personal and professional life. Internet is widely used by students, educational institutes; 

scientist and professionals to gather information for research and general information. 

Businesses use the Internet to access complex databases such as financial database.   

The Internet is the largest encyclopaedia for all age groups. The Internet helps in 

maintaining contact with friends and relatives who live across different locations via 

Internet chatting systems and email software. Internet is also becoming a major source of 

entertainment for the general public.  

WORLD WIDE WEB  

World Wide Web (abbreviated as WWW or W3, commonly known as the Web), is a 

system of interlinked hypertext documents accessed via the Internet. With a web browser, 

one can view web pages that may contain text, images, videos, and other multimedia, and 

navigate between them via hyperlinks.  
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Information is stored on web servers referred to as web pages are retrieved by using a 

web browser such as Firefox on the local computer. A Web Browser is a software used 

to view Web sites and acts as an interface between the user and the World Wide Web. A 

Web server is a computer that stores web sites and their related files for viewing on the 

Internet.  
 

Some of the advantages associated with networking are:  

•Data Sharing: One of the most important uses of networking is to allow the sharing of 

data.  

•Files Transfer  : Users can send text files, spread sheets, documents, presentations, 

audio files, video files, etc. to other users.  

•Hardware Sharing: Hardware components such as printers, scanners, etc. can also be 

shared. For example, instead of purchasing 10 printers for each user, one printer can be 

purchased and shared among multiple users thus saving cost.  

•Internet Access Sharing: You can purchase a single Internet connection and share it 

among other computers in a network instead of purchasing multiple Internet connection 

for each computer. This is very commonly found in Internet café (browsing centres), 

schools, colleges, companies, etc.  

•Usage of network based applications: Such as web browsers, email clients, chat 

application, audio & video calling, etc. is another advantage.  

GETTING ACCESS TO THE INTERNET 

To use the Internet, you need an Internet connection. Internet connections are provided 

by Internet Service Providers such as Bharat Sanchar Nigam Limited (BSNL), Airtel, 

MTS, Vodafone, Tata Docomo, etc.  

INTERNET SERVICE PROVIDER  

An Internet service provider (ISP) is an organization which provides you with access to 

the Internet via a dial-up (using modem) or direct (hard wired) or wireless connection.  

Choosing connectivity depends on the availability of a particular technology, speed and 

connection type in your area. Usually small and medium business users, home users use 

connectivity types such as DSL, cable modem, dial-up, broadband wireless, WiMAX or 
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3G. Medium to large business users or customers with more demanding requirements 

may use high speed connectivity such as DSL (High Speed), ISDN, etc.  

MODEM  

Á modem is a device that converts digital computer signals into a form (analog signals) 

that can travel over phone lines. It also re-converts the analog signals back into digital 

signals. The word modem is derived from its function MOdulator/DEModulator.  

Types Of Common Internet Connectivity  

There are different types of Internet Connectivity available today; it can be widely 

categorized into wired and wireless access. Following table is a summary of different 

types of Internet connectivity categorized into wired and wireless:  

 

 

Some of the commonly used Internet connectivity are:  

Dial-up: Dial-up Internet access is a form of Internet access that uses the facilities of the 

public switched telephone network (PSTN) to establish a connection to an Internet service 

provider  

(ISP) via telephone lines using a device called MODEM. Users dial a particular number 

provided by the ISP and gain access to the Internet.  

Dial-up connections are extremely slow and in most cases, it is replaced by a high speed 

connection such as DSL or Cable Modem.  

DSL: Digital subscriber line(DSL) provide Internet access by transmitting digital data 

over wires of a local telephone network. DSL service is delivered along with wired 

telephone service on the same telephone line. On the customer premises, a DSL filter 

removes the high frequency interference, enabling simultaneous use of the telephone and 
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data transmission. For using a DSL connection, you need a DSL modem and a 

subscription.  

Cable Internet Access: Cable Internet Access is a form of broadband Internet access that 

uses the cable television infrastructure. Cable Internet Access is provided through existing 

cable TV networks; this is similar to DSL that is provided over existing telephone lines.  

3G: 3G, short for 3rd Generation is a set of standards used for mobile devices and mobile 

telecommunication services and networks. High-Speed Downlink Packet Access 

(HSDPA) is 3G mobile telephony communications protocol that allows higher data 

transfer speeds and capacity.  

If support for 3G is available on your mobile phone, you can subscribe to the 3G 

connectivity with your ISP in order to get high speed Internet connection on your phone.  

WiMAX: WiMAX (Worldwide Interoperability for Microwave Access) is a wireless 

communications standard designed to provide mobile broadband connectivity across 

cities and countries through a variety of devices. WiMAX is a long range system, covering 

many kilometres and is typically used where DSL or Cable Internet Access cannot be 

used; this could be difficulty in laying out cables for home or offices located in remote 

locations but need access to the Internet.  

WI-Fi: Wi-Fi is a popular technology that allows an electronic device such as computers 

or mobile phones to exchange data wirelessly over a network, including high-speed 

Internet connections. WiFi devices such as personal computer, smartphones, video game 

console, etc. can connect to a network resource such as Internet through a device called 

the Wireless Access Point (WAP).   

Wi-Fi is used where cables cannot be run (such as old buildings, outdoor areas) to provide 

network and Internet access. Wi-Fi can also be used where users require mobile 

connectivity.  

Wi-Fi connectivity is used in home & offices, hotels, college & school campus typically 

for Internet Access. Shopping malls, coffee shops, resorts mostly offer free or paid Wi-Fi 

access to the Internet for their customers.  

 

DATA TRANSFER ON THE INTERNET  

Having talked of data transfer and the Internet, have you ever wondered how sitting in 

one corner of the world, you get information from another distant area in a few seconds?  
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In very simple language, let’s see what happens to a piece of data, say a Web page, when 

it is transferred over the Internet:  

• Each packet is sent from computer to computer until it finds its destination. Each 

computer on the way decides where next to send the packet. All packets may not take 

the same route.  

• At the destination, the packets are examined. If any packets are missing or damaged, 

a message is sent asking for them to be re-sent. This continues until all packets have 

been received intact.  

• The packets are now reassembled into their original form. All this done in seconds!  

To access the Internet, you need an active internet connection. You need to gather and 

understand your requirement carefully before subscribing to an internet connection plan. 

In this exercise, you will learn how to choose an Internet connection.  

Some of the common questions that help you in your decision are:  

• What is the purpose of getting this connection?  

• Will you use the connection regularly?  

• How much data will be downloaded on an average per month?  

• How much speed do you need?  

• What technology is available in your particular area?  

• What are the different plans available from the ISP?  

• Is there any limitation or catch for the selected plan?  

 
To access Wi-Fi, you need an access point with an active Internet connection. Usually 

when you subscribe to an Internet connection, the ISP provides options to purchase or 

rent a Wi-Fi router that can act as both an internet connectivity device and an access point 
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for Wi-Fi connectivity. Setting up a Wi-Fi network requires technical expertise; however, 

you can access the Wi-Fi network by connecting to an access point that is already setup 

for use. On computers that run Windows XP, you can view the list of wireless networks 

available by using the following procedure:  

• Right-Click on the Wireless Icon in the system tray and Click View Available Wireless 

Networks (figure 10)  

 

 Windows XP will display the list of available Wi-Fi networks; you can choose any of the 

connection from the list. Select by Double-clicking on the name displayed in the list.  

 

Note: You may be prompted to enter a password if the selected network is secure. You 

will receive a confirmation that you are connected to a wireless network. Now the system 

is ready to be used for network related applications such as Firefox, Chrome, Skype, etc.   
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Activities 

1. List any 3 ISP’s available in your city. After collecting information such as connectivity  

type, speed and charges, compare them and state which is the best ISP and why?  

2. Identify the type of network topology in your school lab 

 

ASSESSMENT 

Fill in the blanks: 

1. The acronym for LAN is _________________. 

2. Three types of Wired Internet Connectivity are ___________ , _________ & 

___________. 

3. Three types of Wireless Internet Connectivity are _________ , ___________ & 

_________. 

II. Answer the following: 

1. Define networking? 

2. Give any three advantages of networking. 

3. Explain the term packet with reference to data transfer. 

4. Explain Wifi and its significance. 

5. Compare LAN with WAN 

6. Expand the following terms :  

a. DSL 

b. ISP 

c. Modem 

d. www 

e. LAN 

f. MAN 

g. WAN 

h. P2P 

7. Explain P2P Architecture and how it is different from Client Server Architecture?. 

  

SESSION 3: INTRODUCTION TO INSTANT MESSAGING  

Relevant Knowledge  

Instant messaging (IM) is a form of communication over the Internet that offers an 

instantaneous transmission of text-based messages from sender to receiver. Most instant 

messaging software include the option for performing file transfers, audio chat, video 

calling and conferencing, sharing desktops, etc. apart from standard text chat. Instant 

messaging software is widely used for personal and commercial use. In this session, you 

will be introduced to the concept of instant messaging, the steps to create an instant 

messaging account and also work with instant messaging software.  
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Unlike email, instant messaging happens in real-time and the response from participants 

can be spontaneous. Some instant messaging software allows users to view messages 

received when they are not logged on. These are called “Offline Messages”.  

For utilizing audio and video chat or conferencing, you need to have microphones and 

headsets or speakers and web cameras so that users can talk or see each other.  

Key Features of an instant messaging are as follows:  

• Text Messages can be sent to one or more person (Similar to SMS)  

• Audio calling and conferencing.  

• Video calling and conferencing.  

• File transfers (Not limited to documents, spread sheets, audio files, video files, etc.)  

• Message history (Save messages for future reference).  

  

Instant Messaging Account  

Participants messaging to each other need to be signed in to the same instant messaging 

software. To use instant messaging software, a user must have a valid instant messaging 

account.  

Instant messaging accounts differ in formats; some instant messaging software such as 

Yahoo! Messenger, Windows Live Messenger use email addresses for managing the 

account and software such as Skype use standard names.  
 

 

Instant Messaging Services  

There are two kinds of instant messaging software – application based and Web based.  

• Application based instant messaging software is downloaded and installed on 

user’s computer. Some of the popular instant messaging software are:  

• Google Talk  

• Yahoo! Messenger  

• Skype  

• Windows Live Messenger     

• Rediff Bol, etc.  

Web based instant messaging software is accessed using browsers such as Internet 

Explorer, Mozilla Firefox, Google Chrome, etc. Some of the popular web based instant 

messaging software are:  
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• Meebo  

• Yahoo! Messenger for the Web     

• MSN Web Messenger  

• IMO, etc.  

[ Creating An Instant Messaging Account  

In this exercise, you will learn to create an instant messaging account for using Google 

Talk.  

Google Talk is an instant messaging service that provides both text and voice 

communication developed by Google Inc. Google Talk can also be used for making video 

calls and to view updates from GMAIL mailbox.  

Google Talk is free and is available as application based (users need to download and 

install Google Talk application to their desktops, mobiles or laptops) and web based 

(users can use  

Google Talk through a browser after signing into their Gmail account).  

Before you start using Google Talk, a Gmail account is required. You have learned how 

to create a Gmail account earlier. In this exercise, you will learn how to use Google Talk.  

Note: You need to download and install Google Talk application from 

www.google.com/talk prior to this exercise.  

LAUNCHING GOOGLE TALK  

• To launch Google Talk, Click Start > 

Programs >Google Talk>Google Talk.  

• You can also double-click on the Google Talk 

icon on the desktop if available.  

You need to have a list of contacts that are available 

for chat. If you don’t have any contacts, you can add 

their Gmail account to your contact list by sending 

an invite.  

If you don’t have a Gmail account already you can 

create a new Gmail account.  
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Signing In into your Google Talk Account  

To use Google Talk, you need to sign in with 

your account details.  

After signing in into your Google Talk account, 

you should see a window similar to the one 

displayed below. Now the Google Talk 

application is ready for use.  

   

 ACTIVITIES : 

Create an instant messaging account on any of the application that support instant 

messaging of your choice. 

Identify the devices that support instant messaging. 

ASSESSMENT 

1. Fill in the blanks:  

a. _______________ is a form of communication over the Internet that offers an 

instantaneous transmission of text-based messages from sender to receiver. 

b.  ___________ , ____________ & _______________& Web Camera are required 

for audio and video conferencing. 

2. List any five application based instant messaging software.  

3. What do you mean by instant messages? 

4. Give any three key features of Instant Messaging. 

 

SESSION 4: CHATTING WITH A CONTACT – GOOGLE TALK  

Relevant Knowledge  

In this session, you will learn to chat with a contact that is already added to your contact 

list.  

• Whenever your friend in the contact list is online you can see the person along with a 

green dot as in the figure 14:  
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• You can start sending text chat message instantly by double-clicking on a contact. A 

window will pop up as displayed in the figure below. You can type the text in the text 

box and press enter; the other person will see the text message and respond to your 

message.  

•Go ahead and get the contacts of a couple of your classmates and chat with them.  

 

There are some general rules and etiquettes to be followed while chatting. They are almost 

the same as those that apply for emails.  

•Messages should be short and to the point.  

• Always introduce yourself by name if your screen name doesn’t reflect it.  

• Always ask if the other person has time to chat first - regardless of how important you 

think what you have to say is, it’s not going to be well received if the recipient is busy.  

• In a business environment, know exactly what you want to discuss.  

• Typing your messages in uppercase is extremely rude - it’s considered shouting and very 

aggressive.  
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• Give people time to respond - Multiple questions sent to a recipient before they’ve had a 

chance to answer can seem more like an interrogation rather than a conversation.  

• Wherever possible, give the person you are communicating with your undivided 

attention. It’s not just a sign of respect, but if you have multiple conversations happening 

or are allowing other issues to distract you, you may miss an important point in the other 

person’s messages or lose the gist of the conversation.  

• It’s important to properly end an IM conversation - you may think the chat is over, but 

the other person may not. While you’re off doing other things, they may be sitting there 

staring at the screen waiting for further communication from you!!  

CHATTING ON GMAIL  
In this exercise, you will learn to chat with a contact using the Gmail account through a 

web browser.  

You can also use the chatting services after signing into their Gmail Account. The same 

procedure will be followed while making voice chats, text chats etc. using the Gmail 

Account.  

Once you sign into your Gmail account, a contact window will be displayed either on the 

left side or the right side within the browser as displayed below.  

 
If you would like to chat with a contact, double click on the contact’s name. You will see 

a pop-up similar to the one displayed below.  
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Now you can start typing the message you want to send and the other contact should be 

able to respond to your chat message.  

CHATTING ON YAHOO  

Having learnt to use one IM software, you will experiment with another. In this exercise, 

you will create an instant messaging account for using Yahoo! Messenger.  

Note: You may need to download and install Yahoo! Messenger application from 

http://in.messenger.yahoo.com/download/ prior to this exercise.  

Before you start using Yahoo! Messenger, a Yahoo Mail account is required. If you don’t 

have a Yahoo! Mail Account already you can use the built in option for creating a new 

Yahoo! Mail Account.  

You should a list of contacts that are available for chat. If you don’t have any contacts, 

you can add their Yahoo Mail account to your contact list by sending an invite.  

Note: If you would like to import your contacts from other sources such as Microsoft 

Outlook, Gmail, Hotmail, etc., you can use the import option.   

Having used Yahoo! Messenger, now go ahead and chat with your classmates using a 

Yahoo mail account through a web browser.  

You can also try using other chat services such as MSN, Rediff, Sify, etc. Refer to 

respective websites for further instructions to download and using the software.  
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ACTIVITIES 

 

1. Add more contacts to your contact list and chat with multiple contacts. 

2. Download, install and use Windows Live Messenger, Rediff, Sify messengers. Create 

respective accounts to practice. 

 

ASSESSMENT 

 

Answer the following: 

1. State any 03 rules and etiquettes to be followed while chatting on the Internet. 

2. What are the basic needs to use instant messaging (chat) software. 

 

    

SESSION 5: CREATING AND PUBLISHING WEB PAGES – BLOG  

Relevant Knowledge  

A blog is a discussion style site used by non-technical (or technical users) users for 

creating personal web pages. Blogs are similar to an online personal diary and simple to 

use.  

You can use a blog to convey messages about events, announcements, news, reviews, etc. 

Blogs are usually managed using a web browser and this requires active internet 

connection. You can also use offline blog software to create content first and later publish 

the content when an active internet connection is available.  

There are hundreds of websites that offer blog service for free. Some of the popular blogs 

include:  

• www.WordPress.com  

• www.blogger.com  

• www.blog.com  

• www.weebly.com  

• www.blogsome.com  
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CREATING A BLOG ACCOUNT  

In this session, you will learn how to create a blog account in WordPress.  

WordPress is free web service that you can use to create a beautiful website or blog. 

WordPress has support for “themes” for customizing the design of a blog. Themes can 

make the blog or the webpage look attractive.  

• Before you start using a blog, a blog account is required. To create one, you need a 

web browser and an internet connection.  

• Open the Web Browser.  

• On the address bar type https://signup.WordPress.com/signup/. You should now get 

to a page with the fields Blog address, Username, Password, Email Address and 

Language.  

• Blog Address: You must provide a unique address to your WordPress Blog. This is 

the address which others will use to view your blog.  

• Username: You should choose a username for managing this blog.  

• Password: Securing your WordPress blog account with a strong password is 

important. A combination of uppercase and lowercase letters with some digits along 

with symbols would be a strong enough password. You need to enter the password 

twice.  

• Email Address: You must provide your Email Address here. An activation link will 

be send to you from WordPress after you click “Create Blog”.  

• Language: You can choose your own language for blogging from the list given.  

• Click Create Blog.  

On doing so, you will be sent an email for activating your blog account. Open your 

email and click on the activation link. Once you click Activate Blog, you will be 

redirected to your WordPress Blog Account and you should see a web page similar 

to the one displayed below.  
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Now the blog is ready for use. You will be presented with the address of your blog as 

displayed in the web page above; you can either double click on the link or type the 

address manually in the web browser. Either action takes you to the homepage of your 

blog.  

Once you have created a blog, you need to submit content that you want others to view. 

This process ids called posting content.  

• To create a post, click New Post. A Window similar to the one displayed below 

appears.  

 

• Title: You must provide a title for your post; choose a tile that this post will focus on. 

For example, “School Annual Day Function 2012”.  
 

Using the rich text box, you can type content that you want others to read.  

- Once you have finished typing the content, you need to publish the post for others to 

see.  

- Click Publish Post to publish your content. To view the post, you can type the blog 

address in the address bar of the web browser, you should see your blog along with 

the post (displayed below).  
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You can also add photos, videos, etc. to the blog using the options available in WordPress.   

You can comment on posts published by others. Usually, the comment option is available 

towards the end of the post. Look for options such as Leave a comment, Leave a reply, 

etc. in the blog to comment. For example, in WordPress the comment box is located below 

the post and labelled as Leave a reply.  

 

• In the Enter your comment here… text box, type your comments about the post.  

• In the Email (required) field, type your email address.  

• In the Name (required) field, type your name.  

• In the Website filed, you may type your blog address (Optional).  

• Once you have typed the content in the comment area, review carefully and Click 

Post Comment.  

Once you click the Post Comment, you will see the blog along with your comment. 

(displayed below)  

 

ACTIVITY 

Create a blog of yours using wowrdpress/ blogspot/wix or any other blog service provider. 
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ASSESSMENT 

1. What is a blog? Explain its use. 

2. List any 5 websites that provide blog service. 

3. Difference between web page and website. 

4. What do you mean by publishing a post? 

 

 

 

SESSION 6: USING OFFLINE BLOG EDITORS  

Relevant Knowledge  

If you do not have an active internet connection, you can create blogs using a blog 

application and publish the blog whenever internet connectivity is available.  

There are several free offline blog editors available that can be downloaded and installed 

on the local computer such as:  

• Qumana  

• Windows Live Writer  

• Blogdesk  

In this exercise, you will learn to use an offline blog editor Qumana. Qumana is a free 

blog application that is simple and easy to use. In this exercise, you will learn about using  

Qumana 

Note: You need to download and Install Qumana. Qumana can be downloaded from 

www.qumana.com. Once installed, you can use the program to manage blogs.   

Launching Qumana  

• To launch Qumana, Click Start > Programs > Qumana > Qumana.  

• You can also Double-click on the Qumana icon on the desktop if available.  
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You need an existing blog account to use with Qumana. In this exercise, you will learn to 

use your existing WordPress account with Qumana. Enter your WordPress blog address 

and Click Next.  

• A login window appears. You need to provide details of your WordPress account. 

However, if you wish to use it for other blog services, you need to enter appropriate 

details. Give the WordPress blog address in the Web address field. Enter the 

Username and password of the WordPress account.  

• Click Next > Finish.  

A window similar to the one below appears.  

 

If posts are already available in your blog, Qumana will download and display the existing 

blogs as well.  

To create a post,  

• Click New Post.  

• A window similar to the one below will be displayed (figure below).  
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Note: Enter the title for the post in the Title field and the post content in the area given 

below the page title.  

• Click Publish Post.  

Once you click Publish Post, the post will get automatically updated to your WordPress 

blog.  

To view the published content, open the web browser and type your blog address. You 

can include photos or pictures in your blog to make it attractive. To insert a picture,  

•   Click on the image icon on the right hand side of the application.  

  

• Once you click the image icon, the following window will be displayed.  

                                                            

• Click Browse to locate the image that you want to publish in the blog.  

• Once you click “Browse”, the OS browse window appears, enabling you to locate the 

image to be loaded. When you have chosen the image click Upload & Insert.  

• Click Publish Post.  

To view the published content along with the picture, open the web browser and type in 

your blog address.  

Now try using other blog applications such as Windows Live Writer, Blogdesk, etc. using 

different blog accounts.  

 

 ACTIVITY 

Download and use different offline blog editors 
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ASSESSMENT 

Answer the following: 

1.  Explain the purpose of an offline blog editor. 

2.  List any five offline blog editors. 

 

 

 

SESSION 7: ONLINE TRANSACTIONS  

Relevant Knowledge  

Online transactions have made transactions very convenient and simplified the workflow 

in many forms in a business. Online transactions deals with transfer of money over the 

internet. Revolution in the electronic media has made transaction handling easy .  

Many protocols and security measures have been adopted to ensure the safe and secure 

OLTP ( Online Transaction process ). We are already using online transactions when we 

deposit or withdraw money from an ATM machine, when we make our bill payments 

using our debit/ credit cards. NEFT/ RTGS are some other examples of online funds 

transfer. Numerous benefits of online transactions like, fast transaction speed, 

convenience, low risk of theft etc has exponentially increased its use among people. 

Online shopping is a form of electronic commerce where customers can buy or sell goods 

over the Internet. Customers need to have an active internet connection for viewing goods 

or services offered by a seller; customers can pay online using a credit, debit card or by 

internet banking.  

Online shopping could be useful in situations when:  

• A customer does not have sufficient time to visit stores.  

• Visiting a store is more expensive than purchasing a product online.  

• A product or service that is not available in the local market is available online.  

Some of the popular online transaction websites are:  

• IRCTC, an online portal for booking flight and train tickets.  

• Flipkart, an online shopping portal for buying consumer products.  

• EBay, an online portal for buying and selling goods.  

• Redbus, an online portal for booking bus tickets.  
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To perform an online transaction, all you need is a web browser and an active internet 

connection.  

In some cases where purchasing is involved, you will need a valid credit card, debit card 

or online banking support referred to as Net Banking Subscription. Some websites even 

allow COD (Cash on delivery) where the users can pay once they receive the product or 

service.  

Online Transaction Using Flipkart  

In this section, you will learn to perform an online transaction using Flipkart.  

Flipkart is an online store where you can purchase a variety of electronic goods, books, 

accessories, digital cameras, mobile phones and peripherals such as printers, etc.  

Flipkart offers multiple payment methods like credit card, debit card, net banking, e-gift 

voucher, and Cash on Delivery.  

To work with Flipkart, you need to use a web browser and an active internet connection.  

• Open any Browser such as Firefox, Chrome or Internet Explorer  

• Type www.flipkart.com in the address bar and Press Enter.  
 

A web page similar to the one below will be displayed.  

 

• To perform transactions using Flipkart, you need to sign up for a Flipkart account.  

• Locate and click on the Sign Up link at the top of the web page, a window similar to 

the one below will be displayed for signing up with Flipkart.  
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• Email Address: You must provide your Email Address. The Email Address is also 

used for sending offer mails, promotional mails to you. The Email Address will be 

used as the login name for your Flipkart Account.   

• Password: You must secure your Flipkart Account by giving a strong password. You 

need to enter the password twice.  

• Click Sign Up Now!  

Once you have signed up successfully, a window similar to the one below will be 

displayed.  

 

 Flipkart has a variety of products organized as categories. You can either look for 

respective product in appropriate category or you can use the search feature to locate a 

particular item. For example, if you would like to buy a digital camera, you can Digital 

Camera in the search box and choose a model from the search results window. You can 

select a model of your choice by clicking on the product image. You can browse the 

catalog of products available in Flipkart; once you have decided to purchase a product, 

you can use purchase the product by using the option Buy this now. You can select one 

or more products before you proceed to payment. Products added to your shopping cart 

will be available for review prior to payments.   
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Flipkart allows a variety of methods for online payment. You can use credit card, debit 

card, Net Banking, Cash on Delivery or e-gift voucher to complete the payment; you need 

to enter appropriate details as required in the mentioned fields and Click Pay to initiate 

the payment.  

Depending on the method select, additional windows may be displayed and procedures 

will vary to complete the online transaction.  

Some vendors (websites) also offer payment to be made in installments thus making it a 

convenient option for the customers. Refer to the website payment terms for information 

on payment procedures and practices.  

Online Transaction for Booking Rail Tickets  

In this section you will learn how to perform online transactions for booking train tickets 

using  

IRCTC. Indian Railway Catering and Tourism Corporation (IRCTC) is an online portal 

that can be used for booking travel tickets.  

To work with IRCTC, you need to use a web browser and an active internet connection.  
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• Open any Browser such as Firefox, Chrome or Internet Explorer  

• Type www.irctc.co.in in the address bar and Press Enter.  

A web page similar to the one below will be displayed.  

 

• To perform transactions using IRCTC, you need to sign up for an IRCTC account.  

• Locate and Click Signup link at the top of the web page, a window similar to the one 

below will be displayed for signing up with IRCTC.  

• You will be redirected to a web page for signing up with IRCTC similar to the one 

below.  

Follow the onscreen procedures for filling up the details to complete the registration.  

Once you logon to IRCTC, you can use the website for booking tickets. By now, you are 

quite familiar with what each field represents. Go ahead and fill in the details. The ones 

marked with an asterisk (*) are mandatory fields.  

ACTIVITY 

1. Open various government and private sites for registration of tickets or purchase of 

any product and observe the information asked on such transaction sites. 

2. Visit any online shopping site and observe the details of products published. 
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ASSESSMENT 

1.  Explain the purpose of Online transactions. 

2.  List any five websites that allow online transactions. 

3. List any three payment tools to use online transactions. 

4. Give any two benefits of online transactions. 

 

SESSION 8: INTERNET SECURITY  

Relevant Knowledge  

Internet security is a branch of computer security specifically related to the Internet, often 

involving browser security but also network security. Its objective is to establish rules 

and measures to use against attacks over the Internet. The Internet represents an insecure 

channel for exchanging information leading to a high risk of intrusion or fraud, such as 

phishing. This session introduces you to Internet security concepts and how to secure 

online and network transactions.  

Though Internet provides valuable information and entertainment, it may leave your 

computer unsecure due to many online threats. You need to ensure that your usernames, 

passwords, credit card or online banking information secure as they are prone to be 

tracked and used by unauthorized users. Some websites can also install Malware on the 

computer without user consent thereby leaving the computer damaged or insecure.  

Online threats such as Phishing, email spoofing, chat spoofing, etc. can increase the 

chances of users getting compromised.  

You can reduce the risks by using best practices such as using Antivirus Software, 

Antispyware  

Software, Firewalls, strong passwords, etc. in addition to spreading awareness of the best 

practices.  

Best Practices for Security  

Use strong passwords, a combination of alphanumeric and special characters could be 

used for creating a password that is not so easy to crack or guessed by other users. Do not 

keep passwords such as your favorite color, friends or relatives name, bike number, 

mobile number either as single or combined option. These passwords are easy to guess if 
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a user knows you personally. Change your password frequently at least 2 or 3 weeks so 

that your account information remains secure.  

Using strong passwords can lower the risk of a security breach; effectiveness of a 

password depends on the security mechanism of the software and users involvement in 

generating a strong password.  

Most websites check for password effectiveness when a user attempts to register for the 

first time or when they change password. For example, when you register with Gmail, 

you may notice a password meter displaying the strength of your password similar to the 

one displayed below.  

  

Following is a general guideline for managing strong passwords.  

• Keep the length of the password at least 12-14 characters if permitted.  

• Avoid keeping passwords based on repetition, dictionary words, letter or number 

sequences, usernames, relative or pet names, etc.  

• Including numbers, and symbols in passwords if allowed.  

• Use capital and lower-case letters.  

• Avoid using the same password for multiple sites or purposes.  

• Avoid using something that the public or workmates know you strongly like or 

dislike.  

• Use random password generators if possible.  

       Example of a strong password: u1vX:,4Hd{]$  
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You may also use websites such as www.strongpasswordgenerator.com that can generate 

random strong passwords. To generate a strong password using 

www.strongpasswordgenerator.com do the following:  

• Open any web browser. Type www.strongpasswordgenerator.com in the address bar 

and press Enter.  

• Click Generate strong password. Notice the password displayed under your new 

password. Backup your data: Always keep copies of personal data in additional media 

such as compact discs, pen drives, etc. This could be helpful in situation when there 

is a loss of data. Keep the data away from unauthorized users.  

Use encryption software: (Usually available within the operating system) to protect your 

data from unauthorized users. If encryption software is not available within the operating 

system, use a 3rd party software.  

Keeping your username and password private: Never save your username or password on 

computers that are used in shared environments such as internet café. Browsers may save 

your personal data on the local computer that can be used by another user using the same 

computer.  

Registering with websites: Read the privacy statement or policy whenever you register 

with a website, the statement or policy will include information about how the website 

use personal data.  

Do not share personal information: Websites require you to fill out forms containing 

fields such as name, gender, age, email address, school, etc. Be cautious when filling out 

such forms; research and verify if it’s a trustable website. Your email addressed could be 

used by unauthorized users to send you fake or unwanted emails; think twice or thrice 

before providing information to any website and decide if it is really necessary 

.  

Secure transactions: If you are using online shopping or transactions, websites even 

store your credit card or online banking personal information such as your credit card 

number, account details, etc. This information can be tracked and used by un-authorized 

users often known as hackers to misuse this information. Again, ensure the website is 

legitimate and uses secure practices for performing and maintaining online transactions. 

Since information such as credit card details or personal information is sent over the 

http://www.strongpasswordgenerator/
http://www.strongpasswordgenerator/
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network, it is always recommended to use only secure websites for such transactions. 

Verify if the website uses secure transaction; usually it is indicated through a digital 

certificate represented as a golden lock in the web browser’s address bar.  

Use antivirus and antispyware software: Computers are prone to attacks from software 

known as Malware that could harm your computer. Malware track browsing behavior or 

transmit personal data from your computer; programs such as keyloggers could be 

installed on your computer track and transmit every key that is pressed on a keyboard 

(keystrokes) to unauthorized users.  

Antivirus and Antispyware programs also offer real-time protection monitoring your 

computer for any changes by malware software. Keep your Antivirus and Antispyware 

software always up to date, this can help in protecting your computer from recent threats.  

Do not immediately respond to mails from unknown users: It may be a fake mail trying 

to gather personal information such as your bank account details, home address, etc. Some 

mails could promise you jobs or announce lottery results which in turn could compromise 

the user.  

And in some cases, virus or scripts that are dangerous could be attached to the mail; 

NEVER open the attachment from an unknown source.  

Clear browser cookies frequently: Cookies are programs that are created on your local 

computer when you visit websites. Though cookies are meant for storing data based on 

your activity performed during your earlier visit such as logon details, details of a 

shopping cart, visited pages in a website, etc. they could also be tracked by unauthorized 

users and possibly gain access to your personal information.  

Keep the operating system and software applications up to date, though operating systems 

and applications are designed, tested and distributed, sometimes they may have security 

holes through which a hacker can take advantage; they may track and gather information 

or even damage the whole computer. In general, most vendors notify the users whenever 

a security hole is identified and an update is available to address that particular issue. You 

can also visit respective vendor’s website to check if there are any updates available, 

download and keep your operating system and software applications up to date, free from 

security holes.  
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Install firewalls: Firewalls could be software or hardware and can assist in keeping a 

computer and a network secure. Firewalls analyze the network traffic and determine if 

the traffic should be allowed or not. In most cases, operating systems such as Linux, 

Windows or Mac include firewall software as a part of operating system thus keeping the 

computer secure. In rare cases, you may need to configure your firewall for additional 

security.  

Never install software from unknown sources: As they might not be trustworthy; 

download only from well-known or reputed websites. Verify the source if it is legitimate 

by searching the internet or referring to comments from other users before downloading 

them; understand the nature and the purpose of the software before attempting to 

download and install them.  

Remove unwanted or unknown software applications: These might have got installed 

without your knowledge when you have visited some websites. Unwanted software could 

get installed as they might have been bundled along with necessary software. Some 

programs such as toolbars get installed usually through bundled software and are 

programmed to send personal data without your consent.  

 

Clearing Data Stored In Browsers  

Web browsers have built-in password management designed to store passwords used in 

forms on websites. Browsers often prompt to save usernames and passwords when users 

attempt to logon to websites.  

This facility is offered to users, so that they can logon to their frequently used websites 

without having to type the usernames or passwords. However it is not advisable to leave 

the web browser store this data particularly on public or shared computers.  

To clear personal data from a web browser such as Mozilla Firefox, launch the browser.  

• Click Tools Menu, click Options.  

• Click Security Tab. The following window will be displayed:  
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Notice that under Passwords section, Remember password for sites is checked. This 

means the browser is configured to save passwords for websites automatically. You can 

uncheck  

Remember password for sites option, if you prefer NOT to store passwords.  

Mozilla Firefox can also store data such as cookies, visited websites or webpages data, 

browsing history, etc. To clear this stored data, click General tab > Option. The following 

window will be displayed:  

 

• Click Privacy Tab. The following window will be displayed:  
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• Under History section, click the drop down menu next to Firefox will:.  

 

• Select Use custom settings for history from the drop down list. The following window 

will be displayed:  
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Notice the preferences; Firefox is configured to remember browsing and downloading 

history search and form history and cookies. If you do not wish store the above mentioned 

data, select  

Never remember history from the drop down list. If you are in a public environment such 

as a cyber café, you may select the option Clear all current history. On selecting this 

option, the following window will be displayed:  

 

• Click Clear Now and then click OK. From now on, Mozilla Firefox will not 

remember any history as you have configured it that way.  

• There are several online threats such as Phishing, email spoofing, chat spoofing, etc.  

• You can reduce the risks by using best practices such as using Antivirus Software, 

Antispyware  

Software, Firewalls, strong passwords, etc. in addition to spreading awareness of the best 

practices.  

 ACTIVITY 

Open settings of different browsers like edge, Mozilla firefoz, opera  etc and note down 

the security settings in them   

ASSESSMENT 

1. Explain the purpose of Internet Security. 

2. Explain different kinds of online threats.  

3. Explain the need to clear data stored in browsers. 
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4. Explain any five tips to manage strong passwords. 

5. Explain any four best practices to secure data .  

6. Explain use of Antivirus and Anti Spyware 

 

 

 

SESSION 9 : MAINTAIN WORKPLACE SAFETY  

Maintain Workplace Safety   

Every organization must follow a standard set of safety rules and procedures.  These rules 

must be stated and displayed clearly at important areas . All the employees must be given 

a demonstrations and  training to follow safety rules .  

Basic safety rules to follow at workplace – Fire safety, Falls and slips, Electrical safety, 

Use of first aid.  

Timely repairs should be carried out by a competent person/ organization at workplace / 

home to avoid/minimize any hazards. 

Basic Fire safety rules in an organization are :  

Most of the time fire can be prevented using appropriate measures.  

- Fire escape plans must be installed at proper levels  

- Conduct regular drills  

- Smoke alarms must be placed at proper intervals 

- Keep workplace a no-smoking zone 

- Maintenance of safety equipment must be taken care of regularly  

Falls and Slips Safety rules  

- Keep the moving area clean and clutter free. 

- Workplace must be proper ventilated receive light. 

- Wear non slippery footwear. 

- Floors must be clean and dry  

- Oil spills, dust must be immediately cleaned. 

- .  
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Electrical Safety Rules:   

 Though use of electric equipment has helped in all our routine tasks whether it is at home 

or office  but if precautions and safety measures are not taken  daily then they might be a 

cause of threat to our lives. We must take appropriate measures to ensure safety from 

electrical devices at home as well as at workplace. Following are some of the measures 

we should take to keep ourselves safe from electricity hazards and accidents:- 

- Electrical equipment used should be approved by a recognised organization.  

- Workers should be trained to handle the electric equipment safely 

- Damaged and hazardous electrical equipment should be immediately replaced. All old 

and workout and frayed switches and wires should be changed.  

- Heat emanating equipment should be kept away from the electrical equipment. 

- Take care that the outlets/ circuits should not be overloaded . 

- Switch off  and unplug the electrical appliances before cleaning or relocating them.  

Use of First Aid  

Learning First Aid is the social and civic responsibility of very human being.  If provided 

effectively and on time then it may save life.  

First Aid is the immediate assistance provided to the injured to save life and minimize 

health loss till the proper medical aid/ facility is provided.  

Every organization must have basic First Aid Kit. Kit must have all necessary items. 

Make sure to check for the expiry of medical related items.  

Some rules of First Aid are :  

- Assure the injured to remain calm and not to panic  

- Keep them warm if they are under shock  

- Do not move the victim in case of back/neck injury  

A worker may face Occupational hazards at workplace. : An occupational hazard is the 

illness one may acquire due to his occupation. Like people working in a chemical factory 

may get affected due to presence of certain chemicals. Some types of occupational 
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hazards are : Physical hazards, chemical hazards, biological hazards, , behavioural 

hazards, radiological hazards, ergonomic hazards etc. 

Case studies of hazardous situation 

Following are the examples of hazardous situation when the safety steps are missing or 

are not followed properly. 

CASE Study 1 : Hazards due to Chemicals 

From past 2 years Ramdeen worked in a chemical factory  where come types of Acids are 

being manufactured. He is supposed to carry a sample of chemical in a special flask with 

a tight cap. He went to take the sample from the dispenser and did not fixed the cap 

properly. While carrying the chemical back he slipped and because the cap was not fixed 

and the chemical spilled over his neck, lower half of his face and one hand. The worker 

suffered from severe burns due to chemical burns. 

CASE Study 2 : Hazards due to Electric shocks 

A 43 year old gardener was electrocuted and lost control over his limbs while watering 

the plants in a park where he worked. After investigating, it was found that insulation of 

the electric wire from the night lamp was cracked and full 220 volt current was live on 

the lamp pole. The park care taker had just watered the plants and the electric current was 

live in water while he watered the plants 

This meant the wire was not inspected regularly. Otherwise, the damaged insulated wire 

should have been changed and replaced with a new safe to touch wire 

CASE Study 3: Hazards due to Fire 

A storekeeper was in a habit of throwing the plastic waste and packing waste in the 

backdoor of his store. The housekeeping staff was in a habit of smoking cigarette during 

their break time.  

One week the pile of plastic and packing garbage was not cleaned. One of the 

housekeeping staff just threw the discarded cigarette in that garbage heap of plastics and 

packing material. As the day was hot and sunny, the garbage caught fire. By the time the 

fire was noticed, fire flames engulfed the  whole back area causing heavy damage to the 

store and the backdoor area.  
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The fire could have been prevented if the storekeeper had taken appropriate garbage 

disposal measures, restricting smoking in the premises. 

 

ACTIVITY 

Observe the safety measure adopted in your school and locality. 

ASSESSMENT 

1. Enlist any three basic safety rules to follow at workplace. 

2. Give any two basic safety rules for ensuring Falls and Slips safety. 

3. Give any two electrical safety rules in any organization. 

4. Explain any two first aid rules. 

5. What do you mean by occupational hazards? 

6. List any three types of occupational hazards. 

 

SESSION 10 : PREVENT ACCIDENTS AND EMERGENCIES  

Relevant Knowledge 

Accident: an accident is an unplanned event that may happen all of a sudden and may 

lead to unwanted or unprecedented results/outcomes.  

Or   

It can be defined as an unfortunate incident that occurs unintentionally causing hazardous 

result or injury or unwanted results.  

Types of Accidents:  

Accidents may be of following types :  

- Accidents at workplace : Slips and fall accidents, fire   

- Industrial disease/illness  

- Road traffic accidents  

- Clinical Accidents  

- Sports related accidents  
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Workplace accidents may include injuries that are caused to the workers due to falls, slips 

and trips   

Slip and call accidents may occur at any working environment and the injuries may vary 

from minor ache to major severe accident. Some injuries suffered might include fracture, 

sprain, knee or elbow injury, wrist or head injuries etc.  

Handling Accidents:  

Accidents must be handled carefully. The accident should be handled compassionately 

without assigning blame on others.  

- Every organization must follow SOP for accident handling  

- Safety measures must be placed to prevent workplace accidents  

- Immediately call the medical team for any injury  

- Stay alert  

- Pay attention to and follow emergency drills  

Emergency  

Any unexpected situation that needs immediate attention and action.  

An emergency situation might pose a sudden risk to life, property health etc. and needs 

intervention to prevent deteriorating results/ hazards.   

An emergency situation is one that:  

● threatens the employees, customers or the public  

● disrupts or shuts down the operations  

● causes physical or environmental damage  

An emergency must be handled immediately to prevent further losses and to minimize 

the loss. One must be alert to notice any kind of emergency. There are various types of 

emergencies that may occur at home. School or workplace. Hence it becomes essential 

requirement to have an emergency plan to minimize the loss and recover from emergency. 

Types of Emergency : 

Various types of emergencies are there and there should be an emergency management 

plan to handle the situation of emergency. Some of the types of emergencies are as 

follows :   
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- Chemical spills 

- Extreme heat waves 

- Droughts 

- Pandemics 

- Terrorist attack  

- Fire 

- Floods 

- Thunderstorms 

- Leakage of some hazardous gas/ chemical 

 

Generally the situation of emergency occurs as a result of some disaster. Disaster may be 

either natural or caused by some human activity. 

Some of the types of emergencies that require evacuation are:  

● Fire  

● Explosion  

● Floods  

● Earthquake  

● Hurricane  

● Tornado  

● Toxic material release  

● Civil disturbance  

● Workplace violence  

ACTIVITIES 

Identify some precautions that may be taken at various places to avoid accidents. 

ASSESSMENT 

1. Explain the terms accident and emergency. 

2. Enlist any four types of accidents. 

3. Give any three situations of emergency that require evacuation. 

4. Give any two ways to handle accidents. 
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SESSION 11: PROTECT HEALTH AND SAFETY AT WORK    

Hazards And Sources Of Hazards 

An organization can face some health hazards that could put the lives of the employees 

in danger.  A hazard is anything that is the source of any potential harm, damage or any 

kind of potential loss of health or life. 

Hazards can be of different types depending on the industry and the environment in which 

the employees work. The different types of hazards include:  

● Physical  

● Chemical  

● Biological  

● Mechanical  

Sources of Hazards  

Checklist for Workstations : The workstation should:  

● provide sufficient space for the user to alter position comfortably  

● provide adequate lighting   

● have windows fitted with adjustable coverings to alter the sunlight level  

● be spacious enough when a workstation is shared by more than one person 

The display screen should:  

● display well-defined characters of adequate size and spacing  

● have a stable image  

● have easily adjustable brightness and contrast  

● tilt and swivel easily to suit the user   

● be free from glare and reflections  

● Use a separate base for the screen or an adjustable table   

The keyboard should:  

● be able to tilt easily and should be able to separate from the screen to allow the user 

to adopt a comfortable working position  

● have space in front to provide support for the hands or arms of the user  
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● have a matt surface  

● have clearly legible symbols on the keys  

The work surface should:  

● provide adequate space for the user  

● have a low reflective surface  

● be of an adequate size to allow the screen, keyboard and other peripherals to be 

flexibly arranged  

● have a stable and adjustable document holder, which should be at the same level as 

the screen and at the same viewing distance  

  

Workplace Evacuation   

In case of emergency there should be provision for evacuation. Evacuation is the process 

of emptying a place in case of an emergency, disaster.  

Every company must ensure following points for evacuation in case of any emergency:  

• An evacuation policy : Every organization must have an evacuation policy.  All the 

Team Leaders are responsible for informing about the policy to their employees 

about it. Proper attention must be paid when the Team Leader is informing you about 

these details. Negligence at this time may cost lives.  

• Organization must have a designated assembly point for emergencies. Ensure that 

every employee/ worker must know where it is.  

• A ‘buddy system’ for individuals with special needs or disabilities must be 

designated. This system ensures that differently-abled are assisted and guided out of 

the premises or the impacted area properly. If you are a buddy to someone, ensure 

that your buddy is safe at the assembly point with you.  

• Floor plans with evacuation routes in work areas. Ensure that you understand these 

so you can use it in time of need.  

• Assembly areas, where you are required to assemble after evacuation, must be 

properly taken care of.  

• Periodic evacuation drills should be conducted. Ensure that you pay attention during 

these drills. You need to save your life and you can be helpful in saving someone 

else’s life too.  
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Healthy Living  

‘A healthy body has a healthy mind’ - a very popular saying is true .   

‘Healthy Lifestyle leads to a healthy being. A healthy living has a lasting impact on an 

individual which ultimately yields a healthy environment at home as well as at work 

place. a happy and healthy worker will always perform best to his ability.   

A healthy lifestyle helps to keep and improve people’s health and well being.   

A healthy lifestyle includes :  

- healthy eating habits  

- physical activities  

- stress management  

- healthy mind  

- sound sleep  

- goal setting  

 A healthy lifestyle takes needs practice, commitment and sincere efforts .  

Stay Healthy! Stay Happy!  

 ACTIVITY  

Discuss and enlist the measures to avoid hazards in various situations at workplace and 

in your school. 

 ASSESSMENT 

1. An organization can face some __________ that could put the lives of the 

employees in danger. 

2. Hazards can be of different types depending on the ________ and the 

______________ in which the employees work. 

3. Organization must have a designated ______________ for emergencies 

4. List any three types of hazards. 

5. Give a checklist for workstations to minimize the hazards. 
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6. Explain the term ‘ Evacuation Policy’  

7. Explain Buddy System to implement evacuation efficiently in case of emergency 

8. Explain the terms Floor Plans and Assembly /areas. 

9. Describe the importance of periodic evacuation drills. 

10. Explain importance of a healthy lifestyle. 

11. Give any four points of a healthy lifestyle 

 

 

  

  

 


